Logs downloading

Whenever i try to download any logs from my brand new 3.01 installation on apm 2.5 I get

65443 logs
log 0, start6160, end 65535
log1, start 1, end 65535
log 2, start 1, end 65535

I did try erasing all, but after waiting a lot and getting info that no logs are present i still get this output as soon as I do a flight and try to download log data.

Log] erase
3Erasing logs
X3Log erase complete
logs enabled: ATTITUDE_MED

No logs

Log]

and after test back to old log info that does not let me get anything from the quad. Just crap.

Never had this problem before.

Very few logs are enabled. That shouldn’t matter but could you set the log bitmask back to the default? You should find a drop down to set it back to the default in the mission planner’s Advanced Parameters list.

copter.ardupilot.com/wiki/downlo … t_recorded

Seems that problem is deeper than that. the logs are enabled and I have tried everything. Factory settings restoring included.

I changed the autopilot and uploaded my settings wich worked fine. Seems that flash has problems. Any ideas on how to check it?