Logging prearm check fails constantly


Since a while, whenever I try to arm the plane the safety pre-arm logging check pops up and it does not allow me to arm the plane. I tried switching the LOG_BACKEND_TYPE parameter from 1 to 3 but nothing seems to work. Also tried to enable logging while disarming but I get no files at all. I doubt it is a SD card problem since few days ago it was working, but I reformatted it without success.

I am using Pixracer with Arduplane v4.0.4 and QGroundControl 3.5.6. Also tried upgrading to beta versions in both firmware and QGC but I get the same error.

Does anyone have experienced something similar or have any tips that could help?

Thanks a lot


Update: I tried flashing Ardupilot v3.9.3 and the last daily built of QGroundControl but the problem persists. Nevertheless, I can get log files when I enable logging disarmed parameter. Also tried with another Pixracer and the same parameters but did not experience this problem. Any help/tips would be really appreciated.