Servers by jDrones

LittleBee Pro ESC Pixhawk


(Dave) #4

I’m using BLHeli_S firmware ESC’s on 3 quads with Pixhawk or Pixhawk variants. They work fine. I don’t bother with ESC calibration I just set the range manually in BLHeli Suite.


(davidbitton) #5

I have those exact ESCs on a PixFalcon. I used a Revo w/ Betaflight and BLHeli Configurator to upgrade the firmware and tweak settings. I used the 30A version with a Pixracer. Fine there too.


(Sai Desai) #6

so what range did u set in BlHeli suite and did u do any changes in misssion planner to get it work with oneshot 125


(Sai Desai) #7

just to be clear i am talking abt this esc


(Dave) #8

MOT_PWM_TYPE set to 2. I set the ESC range to 1080 MIN, 1980 MAX but this will depend on your PWM limits. MOT_SPIN_MIN will be a factor as to when the motors start. They are all related.


(Toto Mauris) #9

Could you advice me to set motor timing, ppm center throttle, demag compensation, motor gain, startup power… ?

its 820 Kv motor (angle series) for S550 hexacopter

ftv littlebee 20A Pro


(Toto Mauris) #10

After throttle range calibration and motor direction setting (with blhelisuite), I have tried to test motors with pixhawk.

Safety pressed, board armed with ARMING_CHECK 0 and acro mode.

Mission planned display ARMED, but motors don’t run.

Moreover, I don’t hear any beep when I plug lipo…

Could you help me please ?


(Toto Mauris) #11

After some tries, all motors work fine, excepted motors 2 and 6 (don’t run)


(Toto Mauris) #12

In fact, motors 2 and 6 seems losing calibration at pixhawk startup


(Toto Mauris) #13

It seems to be eeprom save problem. Its possible to move throotle range settings on another eeprom sector ?


(brandon macdougall) #14

I just had to update two" old firmware" of six esc’s and used a old Naze32 card to do it. Made sure everything was the same. Altho some say no need to use mission Planner to do an auto calibration I use it on every new build after a radio calibration. Also check that your little bees are the same type the little bees type s will fly with the non type s but will not program using BLHeliSuite as a group.


(Toto Mauris) #15

Problem solved after throttle range calibration with arducopter and rc

But in case of quick throttle change, the motors sounding “cricks”

Motor timing is currently set to medium, should I change to low ? (Sunnysky Angel A2212 800KV)


(Toto Mauris) #16

I have tried medium low and then low but always “cricks”, when throttle is higher than 2/3 and elev full bottom

I can’t find why (soldering problem ? all welds are good


(OldGazer) #17

Its called DESYNCH.

Brushless motors and 3 phase AC motors use the same principle.

In the AC motor, a 3 phase sine wave is applied to the stator windings generating a rotating magnetic field. As this field revolves it induces a voltage into the armature windings. The induced voltage creates a magnetic field that is the opposite polarity of the field in the stator. This causes the two fields to “lock” together such that the stator field spins the armature (with a certain amount of field slip).

if the torque load on the motor shaft exceeds the stall torque, the motor stalls and will most likely burn up. This is due to the fact that the field slip induces a counter voltage or counter EMF (Electromagnetic Field) in the stator that limits stator current. Take away the CEMF, stator current goes up, the stator windings over heat and burn up.

A brushless motor behaves in much the same way, with one exception: Unlike a synchronous AC motor, a brushless motor is variable speed motor.

The problem we encounter with a brushless motor is if the ESC commands a rapid speed change, depending on prop loading, motor bell inertia, bearing friction, and several other factors, the motor may not be able to “keep up”. When this happens the stator field cannot stay “locked” onto the armature magnets, causing the motor to make a snapping sound.


(Toto Mauris) #18

Thanks for reply, should I increase demag compensation ?


(OldGazer) #19

Read this:

http://www.blheli32.com/operation-manual-for-blheli_32/


(Toto Mauris) #20

The problem is only when pitch is down and roll middle

Should I increase timing and demag compensation ?


(OldGazer) #21

Are you doing this with props on or off?


(Toto Mauris) #22

With props off, no problem when I quickly switch up/down throttle


(Toto Mauris) #23

Could you help please ?

The problem is not solved