Servers by jDrones

Lidar Rangefinder for Pixhawk Cube


(Paul Bealing) #9

Oh and I tried reversing wires as well on all attempts just in case. Nothing


(Paul Bealing) #10

Apologies 0x55 not 05xx was the address. I am trying to change it now


(Paul Bealing) #11

I tried resetting the address on the SF10C to 0x66. I then updated address to 102 in parameters. I get nothing at all.Tried wires both ways and same result. I reset to 0x55 and try wires both ways and get the sonnar range flicking between 2 numbers 122.88 and 163.63. This is killing me. I am almost ready to throw in the towel. Was your LW20 plug and go as in no major issues? I might just buy one of these. At least I know it works for you. I am running 3.5.3 copter. Maybe I should try updating to 3.5.5? Will probably get other issues then!


(Paul Bealing) #12

I also made sure I am getting 5 volts up the line from i2c to the SF10C and it is getting power so I don’t know what the story is


(Rick) #13

Yes. That said, the LW20 uses the same configuration and wiring as the 10C, so you’ll run into the same problems unless the problem is the device itself.

Oh. I just thought of something. Which port are you plugging the I2C plug into? IIRC, the port labeled “I2C 2” on the Pixhawk 2.1 was not enabled until a quite recent version of ArduCopter. Let me look up which version, this might be your issue.


(Rick) #14

Yeah, if you’re using the secondary I2C bus (the plug labeled I2C 2, the primary is incorporated into the GPS1 port), then you might just need to update.


(Paul Bealing) #15

Ahhhh. I see what you mean. Did not realise that the i2c port was not the primary i2c! I will try update and see how I go. Thanks for the new avenues to follow!


(Paul Bealing) #16

So I updated to latest and then tried wires both ways with address of both 85 and 102 and still nothing. I get the 163.63 and 122.88 ranges with the 85 address with wires both ways and nothing at all when I change the address in both APM and the Lidar to 102 (0x66).
I officially give up as am all out of ideas. Such a simple device and so many issues. I guess I will buy an LW20 as you have that working and will try that.
Thanks for your help


(Karu2003) #17

We are now developing up to two meters. https://github.com/ipmgroup/RangeFinder_9xVL53L0X_hardware


(ppoirier) #18

I suggest you upgrade to VL53L1 … you will get extended range :wink:


(Karu2003) #19

Thanks, in Europe they are not yet on sale. I ordered in the USA. We want to increase the number of sensors to 10 directly in Ardupilot. We want to expand the Ardupilot library for the IO expander and for the multiplexer.


(ppoirier) #20

That would be great
I suggest you start optimizing the scanning method so that the average “per sensor “ refresh rate is 10 hz or faster


(Karu2003) #21

We have i2c 1 MHz. :slight_smile: It will be later. :slight_smile: Now we need to decide with Ardupilot Team how to add IO and multiplexer. So far, we’ve done a complete refactoring of the RangeFinder parameters. 64 parameters on all the boards are few. now Ardupilot support already 21 sensor. We have not added one yet. https://github.com/ArduPilot/ardupilot/pull/8816


(ppoirier) #22

Problem is with sensor distance reading time, it is more than 20 msec so if you go sequentially its less than 5 hz for a 10 sensor unit , making avoidance a little marginal


(Karu2003) #23

20 msec is an unavoidable evil. :slight_smile: The rest is solved by tackles and readiness. The conveyor works. :slight_smile: Ardupilot will not wait.


(moonmotor) #24

I had to upgrade to the Beta version of ArduCopter for my liar to work


(ptegler) #25

…bben using the Leddar one units with GREAT success…good for about 40m outdoors


…have a 3D printed case… rock solid altitude hold even crossing various terrain media

ptegler


(Keith) #26

Choppedxs,

I have been trying to get that LIDAR unit to work on the 2.1 since it was released. Like you I have never been able to get it to work, either I2C or Serial. I have bitten the bullet and ordered the LW20/C, hoping it will work, and work well with the IR lock system.

Cheers


(Paul Bealing) #27

Thanks for that note dellphs. Its nice to know its not just me. Hopefully you can let me know how you get on with the new one. I will also check out the Leddarone although I may need better range then 40m. Thanks ptegler.


(Keith) #28

Paul,

I received and installed my new LW20/C. At first I was having the same problem. I went with a serial connection in Telemetry 2 on my Pixhawk 2.1 because I am using the I2C for the IR Lock camera. After fiddling with the setting for several hours I had an Epiphany…The Telem 2 port doesn’t support 11520, which the LW20 is factory set to. So I swapped from Telem 2 to Telem 1 and voila, everything started talking the way it should. I have to wait til next weekend to test fly it, hoping the precision loiter and land work well. Don’t know if this will help your issue, but I thought I would pass the info along.
Cheers!