Large 17inch Copter wobble too much and feels like a ship on high waves

There is a mechanical yaw bias on this frame typical of many frames with round arms. Address it or don’t, in any case you have all the information to continue with the configuration of this craft. Fly it, tune it, you have been given countless guidelines to achieve success.

I will try to attempt a autotune ones able to solve this heating issue with the motors I still want to verify whether the motors are bad bcz the drone flying very stable in the attitude mode and the desire / actual roll and pitch are seems fine and stable enough to start an auto tune.

maybe I will try a new set of motors and props. I will keep you guys updated and always thanks for your endless support :cupid:

We have a 23-inch foldable propeller 25Kg Octocopter flown many times successfully with proper and follow the initialization and setup. The thrust ratio is 2.4 times, estimated. The motor thrust scaling helped us a lot. Test Alt-hold also ensure us we are in the correct direction.

We are lucky with no shortcut, we did it in one flight successfully in each stage. We notice drone CG, and analogue ESC calibration is very crucial to successful flight.

In our experience, with a good motor and propeller matching, the temperature should not go beyond 70 degrees Celcius.

17 inchers are way too much for a tiny 4008. Hence the temps.
I’d go for a maximum of 15x3.6, like the props from the very first generation of S800

@dkemxr @xfacta
Hello guys. Hope u are doing well. I have changed the motors from Martin 4008 to T motors 4014 330kv.

The test was done on a similar setup without any harmonic notch filter setup I am attaching the logs below for the flight. The motor’s thrust hover is below 0.2 its around 0.16.

I will do one more flight to verify the MOT thrust hover value.

I need a bit of help in setting up the reference frequency for the notch filter.

Log
https://drive.google.com/file/d/1CPbdWM3O2ys05LAw_f3yn77RaafqHi__/view?usp=sharing

1st get off on the right foot by configuring for ESC RPM to drive the Notch Filter. You have Dshot600 configured and are running the Bdshot version so do it. Details here:
Bdshot
After configuring the proper parameters review the log yourself and see if ESC RPM is present.
No mystery about what Notch center frequencey and BW to use here:

The RPM sensing is working now

I have changed these params

INS_HNTCH_BW,23
INS_HNTCH_ENABLE,1
INS_HNTCH_FREQ,46
INS_HNTCH_HMNCS,3
INS_HNTCH_MODE,3
INS_HNTCH_OPTS,0
INS_HNTCH_REF,1
INS_LOG_BAT_MASK,1

The vibration increased a lot. i am not sure whether frequencies are accurate.
I have assigned them as per this graph

Logs for the latest flight
https://drive.google.com/file/d/1bWF2HRuHPk-x5uZvWKpvc9CAa1581v0d/view?usp=sharing

  • Set INS_HNTCH_FREQ = below the hover frequency - you can easily determine this by performing a gentle hover and looking at the ESC telemetry data

According to this the INS_HNTCH_FREQ should be around 23?

Ignore the FFT and HNOTCH for now
Your X axis vibrations are incredibly high, and Y and Z axis are a bit higher than desired but they might come good when you fix the X axis problem.

See on the map, your GPS position and IMU position should look like just one line (two lines in exactly the same position). The two diverging lines are indicating the vibrations are confusing the position data.
image

And the vibe graph…

Since the vibrations are very strong in one direction it’s most likely something touching against the flight controller, or wiring pulled tight when it should have some slack.
You dont want a canopy or wiring transferring vibrations to the flight controller or its anti-vibration mount.

  • Secure everything so there’s as little vibration/movement as possible
  • ensure nothing is touching the flight controller or carrier board
  • ensure wiring has enough flex that it’s not pulling against the FC

I do see the photos you’ve got, but maybe some of that neat wiring is touch the FC mount, or there could be a problem with the frame if you’ve got folding arms or something…

I dont understand you battery voltage and current readings, something strange is going on there.
Set these before this thing flies away
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2
FENCE_ENABLE,1
and just wait for a good 3D fix before you can arm.

Hello Shawn the FC is completely isolated and the wire are not touching it, especially the motor wires. Everything was looking under control before I enabled the harmonic notch filters maybe i have used the wrong reading.
See this graph below before the notch was enabled

this was the fight without any notch enabled.
For that same flight, I am attaching the logs. I will do one flight and disable the notch and see whether it will perform the same as different

First Flight Logs ( Harmonic Notch disabled )
https://drive.google.com/file/d/1CPbdWM3O2ys05LAw_f3yn77RaafqHi__/view?usp=sharing

The Notch filter doesnt change the vibrations. It’s basically a measure coming straight from the IMUs.
Vibrations should be below 15

Do the other changes I mentioned before attempting to fly again.

There are several things going on with that flight. The baro data doesn’t make sense and Voltage as Shawn says. And look at these Outputs:


And this Rate Pitch output:

As I believe I have suggested to you before, in these circumstances first set these based on MOT_THST_HOVER. See the tuning guid for proper values.
PSC_ACCZ_I
PSC_ACCZ_P

Leave the Notch Filter setting as they are for now, this craft is not in flyable condition to set those. make these changes and perform a simple hover flight. Then you review the log and determine if the oscillation is reduced or gone.

Here are the latest flight logs with the
https://drive.google.com/file/d/13gDx-jwm8aUKWiaxZn6X8O5Po7siBV7H/view?usp=sharing
MOT_THST_HOVER = 0.17 ( its coming below .2)
PSC_ACCZ_I
PSC_ACCZ_P

What’s the issue with the voltage and current? I am using a holybro power module and it’s showing the right voltage for the battery I check with the voltmeter.

The vibrations are dampened I have tried to give some flex to the cable attaching to the FC.
What I should do with the notch filter.

Which param will affect the rate of rotation ACRO_Y_RATE?

The motor outputs are not oscillating in this log and the vibe levels are fine. I don’t know what was wrong with that previous log but forget about it now. Set the PSC values as directed and run Auto Tune.

Hello Dave, So today i went for the autotune I started with the roll axis the tune was going fine but I am getting the error msg Autotune Failing to lvl tune manually. So should i consider tuning the parameters manually?

After the tune ends (mainly as I observed in the logs) the copter becomes very sluggish and uncontrollable and I have to switch to manual mode to land it. The vibration on the z-axis also increased while the tuning of the X and Y seems very fine. The cube is on the rubber dampers. I try to make them a little bit stiffer.

But pls give me some insight into what happened in the end and why the copter become uncontrollable.

Here are logs and a small visual of the ending after it crashed.
log
https://drive.google.com/file/d/1-0fazwC1Qj8vxWqu7l6m7ShT8bgE86oK/view?usp=sharing

video
https://drive.google.com/file/d/1-qUXDbYdiOFEr575Wz9iB_xCatDPDdMd/view?usp=sharing

These are not set properly.
PSC_ACCZ_I,0.35
PSC_ACCZ_P,0.5
Read this tuning Wiki for the answer:
Tuning
It doesn’t look like you confirmed the Notch filter is working as you still have logging set to pre-filter data. So do that with a simple hover in AltHold.
Before doing another Auto Tune set aggression back to default.

I have disabled the notch but maybe it’s just logging the data.

The MOT_THST_HOVER is 0.1709013

as per the guide

PSC_ACCZ_I,0.35
PSC_ACCZ_I,0.17 ( but unable to change it and keep on resetting back to 0.5 ) ( Check its not going below .2)

Why did you do that? You don’t want to run Auto Tune w/o the Notch filter enabled and configured.
https://ardupilot.org/copter/docs/initial-tuning-flight.html#initial-tuning-flight

That makes no sense. Update to latest Mission Planner Beta from the Help screen.

I got it wrong from the first place I have disabled the notch. My bad I will enable it again do hover and check the logs myself for an increase in vibrations bcz last time after enabling notch all went wrong. I will update.

No change I can observe it doing the same thing not going below.2

No, you check the logs using the FFT tool to see if the Notch Filter is working correctly by comparing it to the pre-filter data you collected.

Perhaps you should read the entire Tuning Wiki. By now some of these things should be basically understood.

I have able to get these values for the copter after reviewing the FFT graphs

INS_HNTCH_BW,23
INS_HNTCH_ENABLE,1
INS_HNTCH_FREQ,46
INS_HNTCH_HMNCS,3
INS_HNTCH_MODE,3
INS_HNTCH_OPTS,0
INS_HNTCH_REF,1


Took the 2700rpm to determine the INS_HNTCH_FREQ

Screenshot 2022-05-29 003503
INS_HNTCH_FREQ at 2700rpm

Just correct me if I am wrong

I will do a test flight and check post-flight logs

I am still not able to set PSC_ACCZ_I = MOT_THST_HOVER ( I think its lowest value can only be set to 0.2 pls confirm me on that )