Large 17inch Copter wobble too much and feels like a ship on high waves

Hello, I have just started tuning this copter done everything according to the tuning guide with the stock PID it feels very unresponsive and the wobbling effect is prolonged but when it tries to level itself it starts to drift to one side. The vibrations seem ok but there are some big spikes as it tries to self levelling. also feels unresponsive but i that it bcz of PIDs bcz as i check the logs the desired pitch/roll seems way off to the actual.

The copter weighs around 3.5kgs with battery top mounted and the CG is a bit off the centre towards backwards

I am using cube orange mounted on rubber dampers. I am attaching the logs from the longest flight i was able to achieve.

I need some suggestions with initial Pids so i can at least feel confident to do a autotune.

1 Like

X and Y vibrations are way too high, Z is reasonable.
Consider if the rubber damping is too much for a Cube. Check prop balance carefully. Check wires are not pulled too tight or rubbing against the flight controller, Check wires are not too loose and flapping around a lot in prop wash.
Maybe show a photo.

Set these to start gathering data for the Harmonic Notch filter
INS_HNTCH_ENABLE,1 ← set this then refresh params to see the rest

Your PIDs are very low, probably from trying to tune with vibrations and noise.
Set these as a relatively safe starting point

And please post the next .bin log after all the fixes, mostly just hover and gentle movements.

Here is the inside look of the cube on the damper. i have thinned out the USB cable as maybe it was transferring most of the vibration and causing vibration x and y-axis

Hello, i have done a test flight today with the updated PIDs the oscillations were mostly eliminated but the motors were quite hot I think bcz of the D term also the MOT_THST_HOVER has increased from 0.2 to 0.24.

The altitude hold was also quite not as accurate I think that due new MOT_THST_HOVER value

here are the logs

The motors are hot because the outputs are oscillating badly.

Because the Pitch Rate is oscillating. Roll doesn’t look that great either:

You have Dshot300 configured w/o ESC telemetry. You may as well use the Bdshot version of firmware so you can use motor RPM to drive the notch filter rather than throttle.

What could be the lead cause for the motor oscillation? I am using folding propellers and the motor is a tarot martin 4008.

is this oscillation due to motors? Arms are pretty steady and not twisting. The copter CG is a bit off from the centre the quad little heavy towards the backside. The CG is around X=-1cm from the centre (were the cube is placed)

how to set up the Bdshot version?

A tuning issue is most likely. Perhaps the high X vibes are from the props. CG isn’t that critical.

Load the Bdshot version of firmware for the Orange Cube for starters. Download the .apj file from here and use the “load custom firmware” option in Mission Planner and select it:
Then set the SERVO_BLH_BDMASK parameter for your motors. After that make a flight and check in the log if you have ESC RPM shown. If so then set the Notch Filter to use ESC RPM instead of throttle.

Docs here:

I have not performed any initial autotune on this setup is there a way we can fix the vibration issue without using the Bdshot? I am curious bcz maybe the copter doesn’t need rpm filtering? i want to find out whether it’s a hardware problem or bad Parameters.

I am not able to bypass the esc to blheli32 suite with the cube i have enabled the required parameters to enable it but the configurator is not able to detect the configuration and version of the esc. Do i need to connect the esc inputs to the AUX channel instead?

Hello, i have done one test with some tweaked parameters I have decreased the PIDs, especially D term a bit and also changed the esc firmware from Dshot300 to normal. Please check the logs

Yes, sure you do. That’s true for any Flight Controller with IOMCU. What ESC’s do you have?

Hobbywing 4in1 60amps

when i am auto analysing the logs the motor balance test is not showing up it’s stating unknown why so?
Have u checked the latest logs or any reviews on that?

The oscillation is reduced but it’s still not good. You should:
Change the outputs to the Aux channels.
Configure for Dshot (300 or 600. 600 is usually the most stable but there are several factors)
Update the firmware to the Bdshot version.
Determine if you have ESC RPM in the log
Change these Dynamic Notch parameters:
INS_HNTCH_MODE,3 (assuming you update to Bdshot, leave it at 1 if you don’t)
INS_HNTCH_REF,1 ( assuming you update to Bdshot, otherwise .26)
INS_LOG_BAT_MASK,1 (no point in logging all IMU’s, just makes for a larger file)

Note: You will most likely have to disable Low RPM Power Protect in BLHeli Suite. If you switch to the AUX chanells you should be able to connect via passthru.

Hello, i have connected the motors to the AUX out and assigned the servo out from 9-13 as motor output(1,2,3,4) and was able to connect to the blehli32 suite ( the updated parameters are stated below)

I tried to recalibrate the ESCs but I am not getting any beep sound to confirm the calibration. *by the way I have changed the sound effect in the music editor

i have enabled all the parameters u listed plus some of these which I found.
SERVO_DSHOT_ESC = 1 (BLHeli32/BLHeli_S/Kiss)

Here is the video of the motors after I arm the setup the motors suddenly stop while running and then start spinning is bcz there

is no load or something else?

You don’t calibrate Dshot ESC’s, forget about that. You don’t want Bidirectional 3D set that back to default. This has nothing to do with Bdshot if that’s what you were thinking. The Motor directions need to be forward or reverse depending on what’s required. Run Mission Planners Motor Test and correct it if it’s wrong.

OK. I got it confused with Bi-directional DShot. i will do a test flight and update the logs. The motors are all working fine and the directions are all corrected.

Hello, I have done the test in the ESC tab I am not able to find anything related or I am not aware of. Please check the logs I have done a test flight.

i have taken a temperature reading of the motors are still getting hot the temperature went from 35 degrees to around 70 degrees the hover was around 4 mins

It still needs tuning, get to it. You can set the INS_ACCEL_FILTER to 10 and set the INS_LOG_BAT_OPTIONS to 2. See if the Notch Filter is working correctly by comparing it to this flight you posted and then run Auto Tune on a windless day.

Probably try AUTOTUNE_AGGR,0.075 too

@xfacta Ok the motors seem somewhat balanced now but are the temperatures increase
due to the motors being loaded to the limit? i was comparing the motor test data sheet they the consuming around 16 amps which is not that much as per the datasheet.

Notch Filter you referring to harmonic notch?

I am a little bit worried about the motors they may touch 100 degrees celsius if try to attempt the auto tune which can take up to 10-15mins