Landing gear reversed with upgrade to 4.0

I am running Arducopter on a pixhawk hex. I was running an older version and everything was fine. I updated 4.0 and the landing gear is reversed. In the old version I had set lgr_servo_deploy and lgr_servo_retract to get the proper servo positions for retract and extend. In version 4.0 I cannot find these parameters anymore. Where did they go. I am using landing gear on RC7 I have tried setting the reverse flag on RC7 but that doesn’t do anything. Can anyone help with how to get the gear output reversed? Thanks

What servo output is the landing gear attached to?
I think you’d set these:
SERVOx _TRIM,{some PWM for default position}

And check the LGR_ parameters for actions.

It is on servo7 and I have tried reverse= 0 and 1, also have swapped min and max to see if that works but it didn’t change the behaviour. I don’t think it looks at the other servo parameters when set to function 29.

What RCin channel are you using? Tried changing any of those settings for that?

Thanks, I will go back and look. I’ll let you know what I figure out.

Thanks Shawn! I was looking at the RCIN channels, not the servos. Landing gear RCIn is mapped to channel 7. The landing gear output is mapped to servo 9. When I reversed servo 9 all works properly. It was more intuitive when the landing gear servo parameters were named lgr_servo_xxxxx but this makes the code more versatile I suppose. Now that I know where to look I can work it out. Thanks again for the quick response. Problem solved!

I had the same issue tonight after upgrading, so thanks for the solution.