Kakute F7 not working with M8Q-CAN over MSP on Copter 4.2.2


Been trying to get the Matek M8Q-CAN working with my Kakute F7 but no luck. The board is running the KakuteF7-bdshot target, and I’ve built the .apj on my local machine. This particular M8Q-CAN unit is running the newer Matek firmware that supports MSP.

I’ve wired TX3 (yellow) and RX3 (blue) on the M8Q-CAN to RX3 and TX3 on the Kakute, and it is being powered off the 5V BEC on the FC. My relevant params are as follows:

SERIAL3_BAUD = 115200

Arducopter is not detecting a compass or GPS at all. I’ve (hopefully) ruled out a UART issue, by connecting the M8Q to where I had a working TBS Crossfire receiver and still no luck. I’ve also tried a few different UARTs, and none of them work.

This particular unit has worked before with Copter 4.1.0 on a Mamba F405 board. Having a spare Pixhawk lying around, this unit also works OK with CANBUS. I’ve got another spare M8Q-CAN, and the other unit also does not work with the Kakute.

Wondering if this is still a configuration issue, or are there some build arguments that are needed for the Kakute to support GPS/compass over MSP?



KakuteF7 uses HAL_MINIMIZE_FEATURES - you will need to use the custom build server to enable this feature

Hi Andy,

Got the build server installed on my local machine, however I can’t see KakuteF7-bdshot in the list of boards. From looking at the build server’s docs though, it uses the list of boards in the Ardupilot repo which doesn’t include the bdshot variant. Is it possible to get the server to build from the list of boards in my local repo instead?



You would need to modify Tools/scripts/board_list.py - for some reason that target has been specifically omitted

That fixed it - thanks!

Out of curiousity why has it been blacklisted? Since I’ve got a working setup now happy to do some testing if there’s a chance for it to make it into the mainstream binaries.

No idea. If it works I think you should do a PR taking it out of the blacklist.

1 Like