Servers by jDrones

Kakute F7 AIO S.Port Telemetry


(Dave) #46

Are you familiar with this?


(Dimitris Arampatzis) #47

Yes I am
I have it already at my big coaxial X8
But at my big copter I use frsky X8R that has smart port in and I get each cell voltage from flvss
Can I connect the flvss some how to holybro and Frsky xsr?


(Dave) #48

I don’t use any sensor modules but yes it should work the same way as your X8R.


(Dimitris Arampatzis) #49

At my pixhawk I connect serial 4/5 too craft @ theory cable too flvss too X8R

So at Kakute I have too connect the uart tx5 too flvss too xsr??


(Jonathan) #50

How-to diagram about half way down the page below:-

http://ardupilot.org/copter/docs/common-frsky-telemetry.html

This diagram…

Although I’m using the new inversion code, so don’t need a special cable. Connected on T2


(Dave) #51

You could probably use T2 but it’s suggested to use T6. See here:


(Jonathan) #52

For reasons I haven’t yet had chance to diagnose T2 worked and T6 didn’t.
I mentioned just in case it wasn’t just me.
Once I’ve had chance to diagnose I’ll report back


(Dave) #53

Any available Tx port should work I would think. I’m using T6 with an inverted Sport input on an R9MM with the serial option set to 4.


(Jonathan) #54

Just reporting back, S.Port worked on T6 this time, not sure what caused previous issue, I can’t replicate it.


(Jonathan) #55

Not sure whether it’s just my setup, but I’m finding telemetry very unreliable, usually works to start with, then falls over after just a few minutes, even though connection to receiver still no problem. Once it drops it doesn’t return without a reboot.

Any suggestions?

9XR Pro, ersky9x, X4R-SB


(David J Gagnon) #56

I keep hearing folks refer to SERIAL4_OPTIONS or SERIAL6_OPTIONS. I don’t see these in Mission Planner full feature list. Am I missing something?

Like many, I am trying to get telemetry from a Kakute F7 working on an r9 mini and have tried using the TX4 to s.port. I set the protocol to 10 (frsky passthrough) and baud to 57 (which I read doesn’t matter). No new sensors are discovered on my X7. I’ve also tried TX6. This inverted/non-inverted mess was one of the reasons I went f7! Any help appreciated.


(Jonathan) #57

The new inversion code uses options. Option 7 is for s.port - (one wire inverted)

SERIAL4_BAUD 57
SERIAL4_OPTIONS 7
SERIAL4_PROTOCOL 10


(Anthony Short) #58

Protocol 10 is passthrough, which is used with the yaapu telemetry script or similar. I don’t get any new sensors discovered on the TX with this option either. Have you tried the script?


(Dave) #59

Install the latest (Master) version of Arducopter for the Serial Options parameters. Also update to the latest Mission planner and you will have a pop-up dialog menu with check boxes to configure the Options.
For example this is the config using the Inverted S.port input on a R9MM Rx. It’s Plane but Copter is the same.


(Dave) #60

I use Yaapu on every model. Copters, Planes and a Rover. It’s great.


(Ricardo Maroquio) #61

Hi, David.
Probably you will not gona make R9 mini work. I hope you do, but I tried a lot. The solution was buy a R9 MM receiver and use SERIAL4_OPTIONS=4 and SERIAL4_PROTOCOL=10 with Yaapu Script and master version of firmware.
Regards!


(Dave) #62

The mini might work but no-go with a Slim. Unless they fixed it with the latest firmware but like you I switched to the R9MM and all was good right away.


(Jeremiah Smith) #63

2019-02-13 190201 Fix the incorrect telemetry issue

It looks like there is an update for the R9 slim. I will test it tonight.


(Jeremiah Smith) #64

I can confirm that it works on an F405-wing with an R9-slim + and the latest firmware. I used the settings suggested by Dave.

SERIAL4_BAUD 57
SERIAL4_OPTIONS 4
SERIAL4_PROTOCOL 10


(Dave) #65

Working for me also with a Pixracer.