Kakute F7 AIO - CRSF - Telemetry problem.

Hello, I’m slowly giving up …
I cannot get telemetry data. Here are some facts.

Here are the hardware:

  • Jumper T16 radio + Crossfire Micro TX V2 + Nano RX V3
  • Kakute F7 AIO V1.5 flight controller

The radio runs on the latest Edge TX (tried different versions and Open TX)
Yaapu 1.9.6 - Recommended for Edge TX
Kakute has a fresh ArduCopter 4.13 installed.
Tried connection via CRSF and Mavlink + RC.
I tried UART 2, 4, 6 (rest are taken).

SERIALn_PROTOCOL 23 (or 2 - Mavlink)
CRSF enabled in Yaapu
I tried to turn off the rest of the UARTs …

All settings in MissionPlanner are made correctly because I had no problems running telemetry on the MatekSys F765-WING controller (arduplane) - and with the same receiver (not the receiver’s fault). Same by CRSF and MAVLINK - no problem.

When I try to get telemetry with Kakute F7 AIO - the radio does not detect any telemetry data except those generated by the receiver.

Now the most important thing - when I install INAV on the same controller - telemetry works fine. So I exclude errors in connections or damage to the board.

Please, give me suggestions, what to do, where to look? I’m sitting for 2 full days on this. I’m about to buy a new controller - but this one works! … kind of … right? …

Yeah the problem is that the KakuteF7 is short on flash so CRSF is not compiled in - you need to use the custom firmware builder to get a version that has this support

Thank you for your respond !

Then why I can’t get telemetry over a Mavlink connection? RC works with RC by Mavlink settings. Telemetry no. I am confused, I do not feel up to compiling software. I barely compile 3d printer software :slight_smile: .
I will invest in a H743 controller sooner. Although I like the quality of Holybro products.

You don’t have to compile anything. Just click the mouse and wait…
Custom Firmware Builder

Holybro has H7 FC’s

I forgot to mention I just have all the cables matched to my F7 AIO. which is quite compact. With the H7 from Holybro or MatekSys I have to use a power distribution board which will complicate the whole build in my case.

It’s working ! I’m still learning, I just love ArduPilot even more now. Thank you very much for your help ! It’s really simple … I wish I knew about it 2 days ago…

Now I have to study the functions so as not to disable something necessary for the flight.

Thank you !