Just switched to a Pix4Lite

Hello, I have been flying FPV with a Naze32 for flight stabilization, and Return To Home. It’s been fun, but now I have a new plane and a Pix4Lite. I’d like to start slow (mission planning later…), and just use the Pix4Lite without telemetry at first, but with flight stabilization. Maybe also RTH and GPS fixed loiter on Xmitter switches. Simple stuff. Can I do that with Plane 3.5? Thanks!

Yes, should be no problem, it can run 3.5.x easily. It’s a 32 bit board. Telemetry is almost a “must have” though as you can then change settings wirelessly and get any warnings or problems wirelessly. It will fly ‘reasonably’ well however on the default settings.

Thanks Graham. I’ve made some progress since my original inquiry. The plane is a Levantex Raptor, with one of those gold Px4Lites from Banggood. The receiver is a little FrSky 4ch with the jumpers in place to send out a ppm signal to the RC input in the Px4. I also figured out how to wire the Px4 to a power distribution board/shock mount so that it functions as a voltage and current monitor. I flashed Arduplane 3.5.2, and have communication to the laptop thru the usb port, and the gps is working. I also can see the attitude indicator for pitch, roll, and yaw are working. With the transmitter on, I can move the rudder and elevator manually. How do I put the Px4 in a mode to get simple control surface corrections for uncommanded airplane motions? Thanks! When I move the plane, nothing happens.

Good stuff, as part of your Mandatory Hardware Configuration in setup you have to set the modes to be switchable from your Tx.
You have to do all the steps in the Mandatory Hardware Configuration in order otherwise you’ll run into problems.

Good news & bad news. Each time I play with Arduplane, I find out a few more things. I actually got all the control surfaces working, and learned that the reverse boxes in radio calibration reverses the FC corrections without reversing the actual servo. Then I learned that the FLTMODE1,2,3… makes the switch associated with Ch5 work. To start, I set it up as a 3 position switch. Manual, Stabilize, and RTL. Because there are many choices for pulse width, I actually set up FLTMODE1=manual, 2 &3 both=Stabilize, and 4=RTL. All good so far, now on to the throttle, where I couldn’t get the throttle to work unless I hit the reverse box under the Radio Cal tab. Even then, it was only max throttle and the Tx stick wouldn’t work at all. Then, I made a mistake by unhooking the main battery with the ESC still hooked up to the power distribution board. I noticed too late the servos were still trying to move. I moved to disconnect the USB which was the only other source of power but it was too late. The servo outputs all died, or became giberish. I think I was trying to pull too much current through the wrong part of the board, i.e., the USB 5V. I ordered a new board, with the idea I will just use a servo instead of the ESC to get the throttle working. If there are any other theories out there about this, I’d appreciate it.

To anyone: I’m pretty well all set up with this Px4 Lite. Man, the prefech maps take forever to download. Main thing, I can’t get the telemetry system to “connect” to GCS. I’ve tried SP#1 and #2, with various options in the Advanced Parameters list. I’m not sure if the Px4 Lite has the hardware RTS pins as described in the Serial Port parameters, or not. Also, in the GCS Initial Setup Tab, under the optional telemetry radio section (sorry can’t remember the name, but it’s a weird name), There are several options for firmware uploads, local and download. Also a copy settings to remote option, etc etc. Is this page supposed to be set up while connected thru the hard wired USB connection? Or with the telemetry? What is the procedure for the options on this page. I’ve tried changing the ID to something other than the default 25, but Mavlink just sets it back to 25. I can retrieve the settings, I can copy them to the remote, but nothing stays after I disconnect. Any suggestions? Thanks!