Jumper T16__Failed to change to LOITER when armed

I have set up 6 Arducopter flight modes in Jumper T16 using the 6P Muiltipos switch. PWM for each mode is tuned at the centre of each flight mode range as shown in Mission Planner flight mode page. When pressing each of the 6 buttons (6P multipos switches), the flight modes changes accordingly when vehicle is UNARMED, with GPS 3d fix.

But when ARMED, both on bench and in-flight, change to LOITER mode failed, with error message saying “…requires position”. But MP clearly shows 3d fix with sufficient satellites and acceptable HDOP.

This happens on both FC, Pixhawk and Revo, both running Arducopter V4.1.2.

My Jumper T16 is flashed with the latest firmware V2.3.11.
GPS_GNSS_MODE is set to 3(GPS and SBAS). I tried setting it to include Glonass, but no change.
I had similar problem and posted in Copter 4.0, but problem seemed to be solved
by setting GPS_GNSS_MODE to 3, but not this time.
Pls see attached param of Pixhawk (Quad S500) and Revo (Quad250).
Quad S500__14 Jan 2022.param (16.7 KB)
Quad250__14 Jan 2022.param (14.6 KB)
Thank you for help.

Probably not. Try 67 for GNSS_MODE and post a flight log.

On bench,I tried 67 which includes Glonass with same result, armed and 3 d fix.

Will try out at field next time to obtain flight log. Thank you.

If that is openTX, the latest is 2.3.14?!


I managed to change to LOITER during flight after changing GPS mode to 67 on one of the quads. Somehow cannot download the flight log.

Still have no chance to test fly the other quad. Will try later.

Thank you.

Change FENCE_ENABLE to 1 and that way you cant arm until there’s a valid 3D fix and Home can be set.
It can take a while on the ground, but you get used wait and it’s worth it to know your mode changes will work in-flight.