JSBSim: No such file or directory, Unable to start JSBSim

Following the guide to build a JSBSim through Arduplane listed here.


Followed the steps and inputted “sim_vehicle.py -f jsbsim:Rascal --console --map”

The simulation loads, but I receive the error “JSBSim: No such file or directory, Unable to start JSBSim”

I have the git repository on the computer, but I’m guessing it hasn’t been added to the $PATH? What should I do to fix this problem?

Pulled the latest version of JSBSim and built the files, but still getting this error.

You need the latest ArduPilot version of JSBSim installed
and in your $PATH

Please get it from git://github.com/tridge/jsbsim.git
for more details

I notice it says “the latest ArduPilot version of JSBSim” but is there a Ardupilot version of JSBSim? If so, how do I get it?

I also followed the instructions and i am getting the exact same error:
“You need the latest ArduPilot version of JSBSim installed
and in your $PATH…”
Does anybody know a solution to this problem? Any help would be highly appreciated!

Obviously Ardupilot and Jsbsim have to be cloned to the home directory for Ardupilot to recognize Jsbsim.

I have the same problem, except that both jsbsim and ardupilot are cloned in my home directory. I have the following entries in my .bashrc file.

export PATH=$PATH:$HOME/jsbsim/src
export PATH=$PATH:$HOME/ardupilot/Tools/autotest
export PATH=/usr/lib/ccache:$PATH

I still get “JSBSim: No such file or directory
Unable to start JSBSim”

Is there anything else that could be going wrong?

Which version of JSBSim are you using?

The newer versions moved things around; the current Vagrant env does this:

export PATH=$PATH:$HOME/jsbsim/build/src

Hey! Sorry for the late reply.
You were right that got it working.