Issues installing wxgtk2.8 for SITL

Hello everyone,

I was trying to set up SITL on Linux VM and when I used the command:
sudo apt-get install python-matplotlib python-serial python-wxgtk2.8 python-lxml

The following error occurred:

Package python-matplotlib is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘python-matplotlib’ has no installation candidate
E: Unable to locate package python-serial

I also tried using wxgtk3.0 but that resulted in the same error as well

If anyone is able to help, it would be greatly appreciated. Thanks

You may need to run sudo apt update first to update the package list.

Which Linux distribution are you running?

I’m running Ubuntu 20.04 and I did apt update

1 Like

Ubuntu 20.04 does not have have the python-* packages as they have moved to Python 3, you will need to run

 sudo apt-get install python3-matplotlib python3-serial python3-wxgtk4.0 python3-lxml

The instructions you quoted above refer to quite old versions of packages.

1 Like


Which instruction are you following ? Our install script already cover this

thank, i solved query