Issues Arming

Seems the only way I can get it to arm is via the Mission Planner. Once armed from the aileron/elev stick, once from throttle, and disarmed from throttle the one time.

Have checked all the params that prevent arming, the only issue is not a good GPS hdop… mostly running 2.7 today, so I disabled that feature, and still would not arm from radio. Tried another receiver. Will not arm still.

Started the firmware upload and setup process from beginning and will not arm at all via radio now, will arm/disarm from MP though. I did notice that even though I went through the wizard again, some of the old parameters (such as the hdop setting) did not return to defaults.

I do have another APM in a different unit that I am going to try next.

I am wired correctly, have checked it at least 6 times.


Apparently I am not successful at sending the download as an attachment, is there a trick, I have the files, but they don’t show up.
Radio: Spectrum DX18, rx AR7010
Battery Turnigy 2200 3s
APM is 3DR
GPS and Mag is RCTimer
Machine is DJI F450
16V, 3300uf cap in system.
China man power module which works on others just fine.
Initial setup.

APM, GPS, and Mag were used in rover previously without issue
MP 1.3.5, build 1.1.5260.33055
Arducopter 3.2

Being Spectrum, Channel ‘throttle’ goes to ch 3 input, signal only
Channel ‘aileron’ goes to ch 1 input on the APM, signal only
channel ‘elevator’ goes to ch 2 input on APM, signal only
channel ‘rudder’ goes to ch 4 input on APM signal only
Channel ‘aux1’ goes to ch 5 input on APM, signal only
spare channel on RX uses power and ground from APM input channel 8, no signal wire.

Voltage at RX is 5.22.

Have gone through setup 3 times reloading firmware each time. It does not always rewrite all the parameters from looking at the hdop parameters as I changed it in one try to 300 to get past a poor signal and it was still there on the next reload.

Regardless the problem has been during the wizard setup (and after if I skip the step) the machine will not arm even though all the above parameters are green and checked. The only times I have had success was when I went to the MP and armed the system by clicking on the tab for ‘actions’ and then ‘arm/disarm’.

One time by some strange thing, the machine was arming with the aileron/elevator stick in bottom right for 5 sec. I checked all the wires and they are as above, and that was the last time I got it to arm from the radio. It will not even do that since the last firmware upload.

At one point I was able to use the CLI and do a motor test, and all was correct.

I have another APM that is in a functional airplane. Going to take that out and try it as I see no reason for this not to work properly. I used the channel input data to verify I am getting signal into the APM BTW.

I hope this is enough info, and that the .log files uploaded.

Also, I thought I was uploading 3.2, but turns out it will only upload 1.5 … so as to not mislead

Well after clearing my EEPROM I got much further but still have an issue

The GFS_THR_VALUE is the prearm message I get, which is more than before. The throttle value at low stick is 1145, high stick 1921, the FS_THR_VALUE is 975, but no matter what the setting is, this continues.

But no matter what the setting or re-calibrating the radio seems to make any difference.

I did try to get 3.2, but the wizard just reloaded the 1.5 and would not let me run the 3.2.

Also, sorry, but it did not make any new log files.

Further information
After ref-installing the firmware and going through the setup again, I disabled the failsafe, and the arm checks and still will not arm.

These are DJI controllers, they work fine on a different receiver without an APM in the middle.

Have tried setting endpoints way down and up to see if that was issue, no change.

Okay found my issue, seems with the Spektrum one needs to have the low throttle endpoint at least at +140.
Can’t fine the way to mark this solved.