Issues after modifying WIFI settings

I wanted to customize the wifi SSID on my v2450GPS and apparently that was a bad idea. After I changed it to SKYVIPERGPS_KST it would never show up on wireless broadcast no matter what i did. Without being able to connect wirelessly there was no way to reset it, until I finally found another forum on here that mentioned putting a facreset.txt file on the SD card. that worked and now my wifi is broadcasting on the original SSID again!

BUT, now, my controller starts up and immediately shows the red INDOOR light, and then freezes up. I can’t even power it off. I have to pull the batteries.

I tried doing the controller pairing setting, going through the web app, click “Pair” and holding the left button while powering it up. It makes all the usual tones and looks like it is trying to pair, but then it just freezes again and i have to pull the batteries. ANY HELP would be appreciated!!!

1 Like

Please does anyone know what I can do? I’ve been trying all day. I’ve even looked through the source code so i could run through all the test modes to see if that would work. It goes through the test modes, but the Transmitter status page doesn’t show any activity at all.

BUT, now, my controller starts up and immediately shows the red INDOOR
light, and then freezes up. I can’t even power it off. I have to pull the

Does it to this when the SkyViper is powered off?

I wanted to customize the wifi SSID on my v2450GPS and apparently that was
a bad idea. After I changed it to SKYVIPERGPS_KST it would never show up on

I made the same change here and the AP works OK for me.

On or off it doesn’t matter. The controller comes on and immediately freezes. I had also just done a firmware update using the app as well. I followed all the prompts and only restarted the transmitter after it said, not sure if that bricked it or not. I was able to factory reset the quad, is there a method to do that on the transmitter?

If I cannot get it figured out today, I’m taking it back to Academy. I REALLY want this drone, but this controller dying, combined with the extremely non-existent official Sky Rocket support (it takes days to get anyone to respond and there is no phone number) and the completely non-existence of replacement parts (the entire store is always sold out) I’m very hesitant to purchase another one and have something like this happen again, after the return period has ended. I don’t want a $150 paperweight.

I found another person having issues with the transmitter after the firmware update.

hi Scott,

no, that won’t brick it.
The most likely cause of the problems you describe is that the batteries in the transmitter are a bit flat. The STM8 MCU starts doing very strange things at low voltages.
If that isn’t it then the second most likely cause is a stuck button on the transmitter. Try wiggling all the buttons to make sure one isn’t stuck.
If those two suggestions don’t fix it and it doesn’t blink at all or play its startup tune then there must be a hardware fault in the transmitter, sorry.
Cheers, Tridge

ok I’ll give it a shot replacing the batteries. I only flew it like 3 times, so I think it is unlikely. Also, if I hold the left button (Mode) it does the 5 second paring action…then just freezes with the Green light lit…still have to remove the batteries to turn it off. I think it is getting somewhere in the code and just having an exception and halting where ever it is.

Also, not sure about a stuck button because i’ve been able to get it into the different test modes with no issues. Anyways, I’ll try new batteries just to see.

If it is a faulty transmitter then my only recoarse is to throw it away because Sky Rocket doesn’t have any of these even listed in their replacement store (actually they haven’t even added this model to the store front yet!) I’m in contact with the retailer, hopefully they’ll be willing to ship me a new copter.

Thanks @tridge. I’m not ready to give up hope one the 2450 just yet. I’m hoping to make it my cheap entry-point into the hobby. I really have a desire to dive into the code and webApp and make changes/improvements, but until I’m confident that I won’t do something that is unrecoverable I’m wary.

@lordneeko I just ran into the EXACT same problem with the transmitter. It just stays in indoor mode or if I try pressing the Mode and On buttons it makes beeps and then shows green GPS light but then gets stuck. Only way out it is to remove batteries. I also saw your question on

I think there is some issue with the TX Firmware update. It IS bricking the TX.

Anyone, Is there ANY way possible to reset the TX ?

@tridge and @peterbarker there is now at least one more person whom this happened to. How would one go about recovering a bricked transmitter?

I suspect the TX can be recovered without the flashing hardware. I would really want to hear from the devs on this asap. This is the fantastic drone, it would be really bad if the TX can not be recovered

And, I also made sure that:

  1. The TX batteries are good.
  2. There is not stuck button in TX.

@lordneeko Quick questions for you:

  1. When the mobile app asked you to update the firmware, did you follow it completely to update the firmware of the DRONE and then the TX in the same run or did you update the firmware of the DRONE and then waited sometime, did something else, possibly turned the drone off and after sometime came back, connected the drone and reopened the app with the app asking you to update the firmware of the TX?

  2. After the firmware upgrade of TX, the app must have shown you the message of power cycling your TX. In that step, how much time did you wait from the point you turned off the TX and turned back on?

  3. After the process of 11 beeps (when TX was actually installing new firmware), did the TX get stuck with a constant red light on or did it show the Green light of GPS? Did you have to do any force shutdown?

  4. How was the signal strength (both data and cellular) of your phone when the TX firmware update happened ? also, how was the GPS reception at that location?

Understanding and comparing exact steps you took would help us both root cause the issue.

  1. As far as I can remember (this was 2 weeks ago) I followed the on-screen prompts exactly. (I already had a v2450HD and the process and app prompts was almost identical). I let the app update everything at the same time as far as i remember.

2&3. Yes there was a message about power cycling. I remember waiting a long time…i think i went to the bathroom and came back…or chased the kids…but i remember it was a while. I heard the beeps. I think I remember that after the beeps that the red/green light were alternating. Not sure if that is what it was supposed to do or not. I guess I could look into the code. Forced shutdown? I cannot remember…I think I just pressed the power button, then back on.

  1. The transmitter and phone were right next to each other. My phone was in airplane mode (still don’t get why that is needed…but it certainly won’t work without it) and signal seemed fine. The video was coming across normally.

Everything else looks ok. This one :

Forced shutdown? I cannot remember…I think I just pressed the power button, then back on.

I think one was not supposed to do a reboot again after the 11 beeps had it all have completed successfully. In an ideal case where the update gets installed successfully, the TX would just reboot normally with a green GPS light and connection to the drone. I remember this did not happen in my case when it failed.

I think there is high probability of having the issue in the actual updated code that was installed or in the loop which was installing this code. It somewhere failed, leaving the TX with half installed firmware ?

I checked the code, it is computing CRC so there shouldn’t be a problem in that. Having said that, I am still trying to follow the rest of the code.

Yes, according to the code, it is supposed to branch to the main_app() after loading the firmware…this means that the SkyViper App is the problem. It is still setup for the old drones (v2450HD would make you power-cycle the Tx too). So the SkyViper app is instructing you to do what you’re not supposed to do. @tridge thoughts on this?
P.S. You guys should open source the SkyViper android/iOS app too. :slight_smile: