Issue arming with Arduplane 4.1.7

Hello. I am currently setting up a wing with ardu pilot using a matek f405 wing. Everything works and I can arm my craft via mission planner, but I am unable to arm my plane using my transmitter. I tried using the method given by the ardupilot fourm(throttle down full right rudder), but I get nothing from that. Any help would be greatly appreciated. Thanks.

In a Manual throttle mode?

Check your radio calibration is correct in MP.

If you’re coming from traditional RC fixed wing: Make sure you don’t have any dual rates on your radio, and make sure you don’t have any trim on your radio. I’ve taken to disabling those features on Arduplane builds that my RC friends fly because trim and rates cause a lot of problems.

So I have re-calibrated my radio and I have also removed all trims and rates that had previously had on my radio, but I am still unable to arm the craft via the tx. I am in manual mode. Ill send a screenshot of my servo outputs/radio cal screen in case I’m doing something wrong. Thanks.

Screenshot 2022-04-06 200558


In the second screenshot, when you hold your rudder stick (on the transmitter) all the way to the right, what happens to the Yaw PWM?

Also, could you post your parameter file?

To get the param file:

  1. Click on the Config tab at the top
  2. Then click on Save to File at the right side
  3. Save the file on your PC and upload it here

Thanks for the help I realized that my radio was setup differently that my FC. I had rudder on channel 6 instead of 4 which is why it wasn’t arming. Now I can arm via tx.

Thanks again