Is Stabalize mode the only mode that functions with FB?

Hi again,

MA SE99 flybarred Heli here,

I have completed most of the setup now and the only mode I have cyclic and collective control is stabaize mode. when I switch to Loiter, alt hold, or auto, the collective traveles to full negative and I have no cyclic or collective control.

In stabailize mode, all is fine, in all other modes, the sticks are dead and the collective travels full negative.

I feel I am missing somthing simple? What am I missing, system is armed and I am able to spool up the heli with blades off. I am using mode 1 for throttle (channel 8) and it works great.

any assistance would be greatly appreciated.


Bobby, Acro should be the only mode which is not working for flybarred helis.

Alt_Hold, Loiter and Auto will show no collective movement unless you are armed. So try that.

Alt Hold should have cyclic control, even when disarmed. If not, please be sure to let me know because that is odd.

Loiter and Auto will have no cyclic control unless armed, that would be normal. And it probably won’t even let you into either of those modes if you don’t have GPS lock.

Hi Rob,

I armed the system by pushing the red blinking button until solid then the servos are alive and travel. Then, I hold the collective stick to the lower right corner until I get a long low tone. I can then spool up the helicopter.

I am watching the HUD for flight mode conformation, it indicates a 3d GPS lock, along with the green light indicated on the PixHawk controller.

Alt_Hold I have cyclic control but no collective. Collective travels to max negative position.

Stabilize looks good, collective and cyclic are acting normal, when I tilt the helicopter the swash response is similar to a FBL controller. (gyros working)

Auto has nothing, when the switch is activated the collective travels to max negative and no cyclic or collective control

Loiter has nothing, collective travels to max negative and not cyclic or collective control.

Best regards,


Are you sure you’re armed, it should say on Mission Planner when you are. I can’t figure any other reason why you’d have no collective movement at all if you’re armed.

What about in Alt Hold? If you are armed, and you raise the collective stick to the top, after the spool-up delay is over, the swash should come up.

Hi again,

And thanks for the reply.

The HUD shows that I am armed and I can spool the heli in mode 1, and I get the armed tone when I hold the collective stick in the lower right hand corrner.

I even loaded all of the setting from a post from DIY drones. I viewed A log file attached on a post from Michel Cote on September 12, 2013 and entered all of his parameters, with exception of a few min/max PWM values of his. Now in stabalize mode I get a normal collective response on the bench when armed but I have no cyclic control. In alt hold and loiter, now the collective travels to max positive range.

Then, I re-configured the swash to H1 and flybarless. Now in Acro mode, I have somthing that might be flyable. I this condition, I have good cyclic throw and collective now has a flyable range and response, With the PID values minimized, I could fly this but nothing else works. In stabalize mode I have no cyclic control but collective is good, but in the other smart modes, (alt hold, loiter, and auto), the swash moves to full positive pitch and there is no cyclic.

Im running out of ideas here, spending many hours typing in numbers and each time I get a different result.

Sorry for being such a pain,

best regards,