Is my OSD board a dud?

I’m trying to install a 3DR MinimOSD board on my hex. I’m using a Fatshark camera/transmitter and an independent 3S battery. It’s all hooked up just like this: … e_Diagrams

I plug it in, and only get a grey screen. No video, no OSD overlay. Two red lights on the OSD board light up. When i hit the reset button on the OSD another light flashes green. I’ve triple checked the camera/transmitter without the OSD hooked into them and they both work well. Is this a problem with my OSD board, or am I missing something? I bought it right from 3DR, but before I try to return it, I wanted to make sure I’m not missing something.

Any help would be greatly appreciated!


Do you get an image if you have the camera linked directly to the transmitter, no OSD in the loop?

Have you tried connecting the two solder pads on the OSD, and not connecting the 12v lipo to the OSD, just have it going straight to the transmitter?

Thanks Mark. Yes, all the gear works perfect without the OSD. I tried connecting the solder jumpers and taking the 12v off the board. No luck. Just a grey screen. Sounds like a dud. I think I’ll be returning this to 3DR.

Might be a silly question but are you powering up the apm/pixhawk as well?
My goggles show static to start with followed by a grey screen when I power up the vtx and osd, and only showing the cam/osd feed when the pixhawk battery is connected.

Failing that it could well be a dud.