Is my accelerometer broken?

Hi all…new guy here. I’ve read through the forums a bit and not found anyone with a similar issue, so I am hoping someone will be willing to help out directly.

First, my setup: I’ve got a DJI F550 hexacopter, with an APM 2.6 w/external GPS attached to an AR8000 receiver, and a Spektrum DX8 transmitter. I’ve got ArduCopter 3.2 on the APM, and am using Mission Planner 1.3.19 as my ground station. I’ve flown the copter a handful of times before (like I said, new guy), but a hard landing (what some might refer to as a “crash”) this past May led me to putting the copter away for a bit. Now that I’ve got some free time again I am wanting to get this back in the air and learn how to fly it properly.

My problem? I can’t arm the copter. Trying to do so gives me nothing…no beeps, no double-flashing red light, no error message in the artificial horizon display. The reason I wonder about the accelerometer is that when the copter is on my bench and plugged in to my laptop, the display shows my ground speed, altitude, yaw, and vertical speed all constantly changing. Is it possible that the crash (er, hard landing) last year could have broken something? There are no other symptoms of problems - I don’t get any errors, I was able to go through all the calibration steps without difficulty, etc. But to look at the instruments, you would think I was bouncing the craft around like a yo-yo.

I’ve attached a screenshot of my mission planner display. On it, the roll, pitch, yaw, altitude, verticalspeed, alt_error and ber_error values are all in constant motion. Interestingly, if I pick up the copter and move it about, the AH responds perfectly normally. It’s as though the system just can’t find and hold a zero value.

Finally, two last observations. One, don’t worry about the ‘RTL’ shown in the AH display; this was just for screencap purposes, it’s always in ‘Stabilize’ when I try to arm. And two, disabling all of the pre-arming checks doesn’t let me arm the system, I still get no response. I don’t know if this means anything or not.


Providing tlogs and/or data flash logs will help to determine if you have an IMU issue.

I’m just now learning how the logging works…hopefully these are the correct logs.

Your logs are set quite low, enable IMU and try again, at least that would show what the accell and gyros are reading.

The attitude is wandering around as you are seeing though, so its not happy. when you power on is the flight controller stationary?

Sounds like to me is that you are not powering the Pixhawk from the battery. You should at least get a red flashing LED when you plug the battery in. The fact that it displays when you plug in the USB cable tells us that the Pixhawk is working.

If the copter won’t arm it will sound out some bad beeps in 3.2.


I’m not quite sure what this means. How would I “enable IMU”, and what does it mean that my logs are “set quite low”?

Yes. The copter is stationary and level on my workbench.

Well, it’s an APM 2.6, not a Pixhawk. When I’ve tried to arm the copter “for real” I have it powered from the battery, but you’re right that I often have the battery disconnected when I am trying to troubleshoot the accelerometer issue. Having the battery plugged in or not doesn’t seem to make a difference at this point.

What I mean is not enough log types are enabled. You need to enable more logs including IMU. IMU has the accelerometer and gyro values in it.

Check the Wiki on how to do this. … og_bitmask

OK, latest update: in the course of setting things up to log more data (I set LOG_BITMASK to 131070, to log as much as possible - thanks for the pointer, RabbitStu), I decided to mess around some more with trying to get the copter to arm. Even though I KNOW I tried it before, this time down-and-left armed the copter! I know that’s an easy fix, so I’m not too worried about it - I’m just glad the system armed. Surprisingly (given the accelerometer issues) it armed with the pre-arm checks enabled as well as disabled.

However, I am still worried about the accelerometer readings - I’m afraid to fly it without understanding what is going on there, so I still appreciate any advice. Latest log attached below.

Are these logs from indoors?
I ask as you’re gps hdop is quite high , high enough to stop the copter from arming as your pre-arm checks need it to be below 2.

Have you checked the hud when you outside? The code uses gps velocities/accelerations to compensate for centrifugal force. A poor gps signal (ie indoors) results in this compensation being a little off but it should settle down when armed.

You can test it by setting AHRS_GPS_GAIN to 0, writing parameters and seeing what the hud does. If it becomes still then you have nothing to worry about and can change it back to 1.
If it still keeps moving then it’s something else.

MarkM, I think you’re on to something here.

Yes, these logs are from indoors. It didn’t even occur to me that GPS could be the problem, as I’ve never had GPS issues indoors before. Of course, I’ve moved since I last flew the copter, and whereas before I was in a single-story house with big windows and a nice view to the sky, I am now working in a basement. GPS reception is definitely sketchy down here.

I took it out back under the deck, and the instability improved dramatically. Tomorrow I’ll go out into an open field and see how things look, but I suspect it will be even better. I’ll report back then.

I meant post a data flash log, but looking at the TLog data I can’t see anything wrong with the accels, the values look normal enough to me. The horizon gimbal moves a bit, but not alarmingly so…I probably wouldn’t have noticed if you hadn’t pointed it out.

I looked at your log quickly today. AccZ look good in the Tlog

About GPS, it’s never good indoors. It’s unreliable due to multipathing. It can even report a low hdop. But it would be wrong. Hdop is indicative. It’s not an exact measure. Unless you have a clear view of the sky GPS is untrustworthy.

I took the copter out in the backyard today, under the open sky, and the problem does seem to have cleared up; there’s still just a bit of wiggle in the data, but not nearly as much as before and not enough to cause me to worry.

Thank you to all who helped me out, it’s much appreciated. Now to learn to fly this thing without any additional “hard landings”!