IRIS+ weird motors behavior

I flew my IRIS+ for the first time last week. I had a few successful flights including flying simple missions.
Upon a normal landing 2 of the motors stopped too early. Now if I try to start the IRIS+, the motors start one after the other as I increase the throttle. Obviously the copter is not flyable.

I tried reloading the parameters and calibration but this is not helping.

Any idea?

Something must have happened with your radio or ESCs.
I actually caused this issue by changing the trim on my radio. I wanted the radio calibration to be more close to center and my upper and lower numbers to be 1000 and 2000.
After doing a radio calibration the motors due just what you described.
To fix this you need to do an ESC calibration and maybe a radio calibration as well.


Mike: thanks for the response. I will try the ESC calibration ASAP.

I tried the ESC calibration and I still have the same problem.

Should I try to reprogram the ESC (assuming that this is possible) ?

I guess I am going to contact 3DR…

The problem was fixed (after contacting 3DR) by running the ESC calibration per this video:

Note that the ESC calibration from Mission Planner did not fix the problem.

Sorry to be picky but it might be useful for anyone else looking.

Mission Planner doesn’t do an esc calibration. It has always had to be done per the video link you posted or - … esc-motor/

I don’t want to be too picky either but my confusion came from the fact that there is an ESC_CALIB option in the terminal of Mission Planner.