Iris+ Receiver not working with transmitter. What to do?

I have the usual equipment, FS-TH9X transmitter and D4R-II receiver. I upgraded to Copter 3.3-rc11, and then the transmitter stopped working correctly. That could just be coincidental to the problem at hand. I downgraded to 3.2.1 and still having the same problem.

Everything else works fine, the 3dr usb radio works when hooked up to my Mac, and APM is getting telemetry from the Pixhawk.

The green light on the receiver changes from red to green when I turn on the transmitter, but that’s all I get. There’s no telemetry about altitude, battery, or satellites coming to the transmitter. When I try to Calibrate the radio, APM says “Radio control is not active or turned on”.

The lights on the FrSky DJT are steady red and flickering green.

I’ve tried binding several times, in different sequences. When binding, the transmitter beeps about once per second, the green light is steady, and the red light flashes, maybe 8 times per second. On the receiver, the red and green lights are steady when ready for binding, and then the red light flashes at about 8 times per second when the transmitter is turned on in binding mode.


Tried it again and now I’m getting battery information, satellites, and distance. But still when I look at the calibration screen in APM, I’m getting nothing, and if I hit the Calibrate button I still get “Radio control is not active or turned on”.

How could I be getting battery and satellite information, but not be able to send commands?

I believe to properly bind, you put the transmitter into bind mode, with the receiver OFF, then while holding the bind button on the receiver, you power it on. After a couple seconds, it is bound. Turn off receiver first, then transmitter. Then power transmitter, then receiver, all should work. :smiley:

I’ve tried all different ways of binding, and now I think they all work. The red lights start flashing together when bound, and then after restarting, the red light blinks when the transmitter isn’t on, then it goes off and the green light comes on steady when the transmitter is turned on.

So I think the receiver is receiving some signals from the transmitter, but it may not be sending anything to the Pixhawk. Or if the Pixhawk is getting signal from the receiver, there’s no information coming back out through wherever it’s supposed to come out. I mean, the Iris+ has two radios, and I’m not sure exactly what the other one does.

I’m confused about what to test next. There’s the connection to the RC pins on the Pixhawk, then there’s another set of wires that go to some kind of shrink wrapped circuit board, and then wires come out of that and go to Telem2 on the top of the Pixhawk.