IRIS motors won't spin up after arming, calibrating


I’ve completed a few flights with my new 3DR IRIS over the past few days. For the most part the copter has performed as expected. However, now when I try to take off, the motors spin slowly without enough power to take off. Even at full throttle the motors don’t spin fast enough to lift off.

The last time it was working I had the Tarot gimbal attached, and I had loaded the “Iris with Tarot Gimbal.param” default settings after selecting the ‘V’ frame type.

Since then, I have removed the gimbal. So, I reloaded the Iris.param default settings. There were problems loading the settings and the copter’s LED started displaying two quick yellow flashes. I reconnected and loaded the default settings again, but I still had the flashing yellow LED. At that point I loaded the new firmware (3.1.5) when prompted in MP. That did not go smoothly either at first. I got the error “No Responce from board” (sic), but after several attempts the firmware seems to have loaded. Still at this point the copter will not take off after arming. There is just not enough power sent to the motors.

I completed the radio calibration, ESC calibration, and accelerometer calibration, but it still will not take off. During the ESC calibration when the throttle was passed through directly to the ESC, the motors would spin very quickly. So, the ESC seems to be working fine, and the battery is fully charged (12.52V). Still after calibrating the ESC, the motors will not spin up to full speed when given full throttle in Altitude Hold mode or even Stabilize mode.

Any ideas? I have a feeling that the firmware update or parameter load messed up something. Is there a way to reset everything to the default settings?



Proceed as follow:

1- Go to CONFIG/TUNING >> Planner and scroll down. Find the bottom check boxes and be sure you have checked on “Advance view”.
2- Go to the upper right corner on your screen and find the two drop-boxes menus, select the proper COMPort your computer assigned for the PX4 FMU board and be sure you are on 115200 as a baud rate, then click on Connect.
3- When the MAVLink connection is Done, please find Advance Params (same CONFIG/TUNING menu).
4- There, you must click on Find and type “THR_MAX”. This parameter must be set at 1000, if is not, please adjust this to 1000 and click on Write Params.
5- When the parameter is successfully saved, just click OK. Disconnect from Mission Planner and test as before.

Hope this helps!

Yes, you hit the nail on the head! THR_MAX was set to 80 instead of 1000. It looks like I had inadvertently loaded the parameters for 3DR_Aero_RTF.param before restoring it using Iris.param.

The problem is that Iris.param does not contain all the parameters.

I compared the 3DR_Aero_RTF.param and Iris.param against the full list of parameters in MP. Many of the parameters in 3DR_Aero_RTF.param do not appear in the full parameter list in MP. I guess some of those parameters are outdated. So, I have ignored those. However, there are five parameters available in MP that are set in 3DR_Aero_RTF.param but are not overridden in Iris.param. So, I would like to double check that I have restored them all the the factory defaults for the Iris.

The five active parameters in 3DR_Aero_RTF.param that are not in Iris.param are:


Judging from the parameter descriptions, I think that they should probably be reset to the following for the Iris.


Probably RELAY_PIN and CAM_DURATION do not have any affect on the Iris since there is no built in camera. So, I’m not too worried about those, but I want to make sure that I have reset BATT_AMP_PERVOLT and BATT_CAPACITY to the correct defaults.

I think that loading the wrong parameter file is a common beginner mistake. So, perhaps adding the parameters like THR_MAX to the default Iris.param would prevent a lot of common problems if someone mistakenly loads the wrong parameter file.

Also, is there a complete parameter file for the IRIS that includes all the parameters available in Mission Planner that could be loaded to perform a complete reset to the factory default settings?