IRIS motor problem one has no thrust

I think I have an ESC problem

IRIS has 30 flights or so, when the quad is armed, one motor will not spin up but will run smoothly if the throttle is advanced a little. If I try to lift off, the motor does not have enough thrust to fly, even with the cyclic stick pushed in the opposite corner it will add power, but it seems like it only has half throttle avaiabe on that motor.

I followed the YouTube vid on ESC recalibration, and re- loaded the original parameters shipped with the quad, (I saved them to a file), but nothing has changed.

The motor spins free, it does not seem there is anything mechanical wrong with the motor.

Thinking back, the last flight today it performed a aggressive landing in auto off a 25meter highwaypoint. And it seemed a little unstable in a few areas of the flight. Should only decend at .5 m/sec?? It came down muth faster than normal. Not sure why, the only thing I changed is the waypoint speed from 500 cm/sec to 600 to speed it up a little between waypoints. The next flight, almost tipped it over on takoff because of the motor issue. Front right motor has no power.

Any help would be appreciated.

When you did ESC calibration(all or one by one), that motor was spinning at normal speed?
If was running at normal speed (comparing to the others), then motor and ESC is OK.


Calibrated all of them.

Plug it in throttle high, un plug, plug it back in and wait for tone, push button lower throttle, listen for tone, and unplug for 10 seconds.

The front right motor would not spin when I when I armed or placed the rudder stick in the lower left corner. It would spin smoothly if I bumped the throttle a little and got it spinning and then lowered the throttle back down. It seems lazy and if I move the cyclic stick corner to corner at partial throttle (when the quad is light) it appears to have limited throttle maybe 50 percent or so. Compared to the other motors. It almost makes enough power to fly with gopro off of the front.

I’m supprized and impressed the quad did not crash, I think it prioritized level over decent speed on my hard landing described above.

Try to calibrate ESC one by one (no props). This is described into wiki.
You will see if each motor behaves as the others. You use just throttle when you calibrate individual. This calibration would isolate a bad ESC or motor.


I looked at the wiki in manual ESC calibration, and took the PixHawk out of the loop and used the reciever. Not exactly obvious which pins on the fssky reciever arechannel 3. It has a single -bus cable set horizontal to the case going to the pixhawk and a jumper on the other side.

So, I used a different reciever that I was familiar with for the test. Nothing obvious that I could really identify by runIng the different motors separately without load. They all spun fast and seemed to respond normal.

Anyhow, I went poorly again with the IRIS back together, when I advanced the throttle, and my angry IrIs tried to kill me. Had the mode in loiter (don’t know why), and when I armed it andI attempt to spool up, it spooled aggressively and nosed over on the week motor side. It still did the same thing, the motor in question was lazy.

Anyhow, I got out of the way, but it made it to the concrete for a good crash.

So the damage: but it broke a arm, ripped the wires out of a rear motor (it couldn’t be the one in question!), broke the lower clam, broke the battery dooor hinge, and ripped the cable off the LED on the battery door and of course a few broken propellers. Other than that it’s all good.

I think it is time to shotgun this with a new ESC and motors, who knows what’s wrong now. It took a good hit on the concrete and flopped around. I don’t see any parts listed on 3dr’s site. I have contacted them yesterday before the crash, they said to e-mail them on there help line so I did, nothing yet.

Not sure how their support is, guess I’m going to find out.

Maybe I should stick to traditional helis,

I have recieced a few E-mails from 3DR

they requested a short video of the damage and asked if I would perform the radio calibration and the ESC calibration.

I peformed both and sent them the Video, and both calibrations did not fix the problem, but the troubble shooting process is ongoing.

so far so good, 3DR seems responsive to the problem.

I was informed the the upper and lower clamshell were not for sale for some reason and that the problem would have to go to a higher level to get that peticular part, along with the ESC. seemed a little odd that a piece of plastic is “not for sale”

Anyhow, I feel the IrIs is a great design and a lot of thought went into it. Quality build in comparison to other consumer quads I have seen. just would like to fly it again.


I replaced the weak motor in question and the motor damaged in the crash (wires ripped out) and the quad is up and flying now. On the ESC, one of the copper solder tabs was lifted off of the PC board from the factory. this was on one of the suspect weak motor connections so a possibe cause. I changed the motor and soldered the connection then glued it back down to the board to test. I sent 3DR a video of this.

not real comfortable with this fix. This might be why the new ESC have crimped wires on the board. But for now, it will fly now and the problem is solved. so, I am not 100% sure if gluing the pad down on the board fixed the weak motor issue or replacing the motor fixed it.

So, I still feel I need a new ESC, im not sure if I have only a mechanical “glue” connection keeping this thing flying.


Hi guys,
I have the same issue. ESC and radio are calibrated successfully. Test motors shows motors spinning correctly.
Even in ESC calibration ( end point limit percentage is 100% instead of 140% on futaba) otherwise esc couldnt get the correct max min settings.
After the apm arming in Stabilize Mode engines start smoothly all in the same time but… unfortunately are very lazy… maybe 20 % of throttle ??Even if throttle is full engines spin 20% no reaction for further actions. I can only stop engines. However when different channels are in use or drone position, part of motors are accellerating but rest of them are still lazy. Quad cannot hover. Impossible at the moment.
How to fix it? I’m using the latest version 3.1.3.

My setup is:
Radio module FRSKY
ESCs Turnigy Basic 18A.

Hi pawelus,

I had (what i hope is )exactly the same problem on my newly built tricopter this morning. The problem for me was that for some reason my pixhawks Max throttle setting was set to 80 , not the 800-1000 that it should be. The Max throttle setting can be found in the full parameters list and is listed as THR_MAX. The arducopter wiki suggests that it is left as 1000. Hope this helps