IRIS+ First flight and many problems

So… first thing I disabled geofence, I was in my courtyard, many tall buildings around so, no GPS fix.

First try to arm motors with radio on and mavlink connected to my tablet, and TOWER running. It say it cannot arm for “Gyro cal failed” . So I went in the gyro calibration using TOWER function, and it say done correctly. Now it cannot arm because say “wrong altitude” or something like that. What is this problem ???

Finally got an arm leaving Mavlink /TOWER disconnected, but even in this situation sometime I can arm and sometime I do not get the blue led and when I try to arm I hear two low tones. Why ??

Third problem: I Have fly to 10/15 meters, and then I got a GPS fix, solid green light on IRIS, and radio show 5 satellites. I have try to switch in loiter mode but the IRiS start to move in erratic and dangerous way left and right, so I immediately switch back to stabilize. Why ? Maybe 5 sat are not enough ? or, there is a “sat calibration” somewhere?

Fourth problem: I try the switch “land”. The first time IRiS completed the landing perfectly. The second time, after touching the ground, motors were still spinning at high speed, I put the motor stick in disarm position, but the IRIS seem tp understand “aileron left” and turned on its back scratching all the props, then finally I got it disarmed…

I am so sad, maybe I have a defective unit ?

I have not done any change in the parameters, apart from disabling geofence…

thanks if someone can help.

Even though the light turns green it may not be good enough. HDOP should be less than 2 for Loiter or Position Hold.

Also tall building cause the GPS signal to bounce and can lead to GPS position jumps. Flight logs would help here. When you look at the GPS plot you may notice it jumping around where you didn’t go.

Land detection has changed and don’t know what release you are running. Version 3.2.1 has addressed this issue.

As far calibration issues are you making sure the copter is level and still when you plug the battery in. No movement is required when it is flashing red and blue on startup.


That is a good starting point for next try, thank you for the informations.
Do you have some clues fot the TOWER messages, also ?

Today second flight in an open area. Much better than first try.

7-8 sat connected, loiter mode works perfectly. I have tried

failsafe for low battery with RTL

during flight Mavlink connected with Mission planner on a windows 8.1 tablet
and also another flight with connection to Droidplanner 2 on my Nexus 5

Also tried a flight controlled only by Nexus, in GUIDED mode. Take off, then “go there” tapping on map, tjen RTL.

I begin to love my IRIS… but still many things to learn.

I forgot to mention:

I have tried this sequence:

  • connected Mavlink to my Nexus 5, running Droidplanner 2
  • using only the Nexus, armed motors then I have click on “takeoff”
  • the IRIS+ has rocketed to about 7-8 meters (I guess) and it was in “guided” mode, waiting for input
  • I have moved it briefly in 3/4 locations tapping on the map
  • Then I have set “Follow me” and begin to walk, but IRIS did not move. I have tried to change his position setting to “above” and reduced radius (it should be the “sensitivity” to my moving), but it was standing still anyway.
    Some idea on this ?

Another question I have for Mavlink / Droidplanner: already at 40/50 meters from IRIS+, Droidplanner say “weak signal”. I have not changed any parameters regarding transmission, I have not checked but I suppose it is at full power. Is this message normal ?
Some way to check the real level of the signal ? (and evaluate it… which is a good level?)

And last: what happens if connection is lost between IRIS+ and Mavlink, during “Guided” mode ? Or “Auto” mode ?

Thank you for your help !

I would definitely not fly in the courtyard until you really have a lot of practice with the Iris+

I had problems with MavLink disconnecting, or failing to connect. It turned out to be the USB cable was loose where it plugs into the radio. I taped the cable to the plug tightly. No problems since then.

Sometimes Follow Me can be a bit slow to kick in. Even though you reduced the radius, try walking even further away. At least 50 meters. Once it locks on, it works well.
Just be aware of a problem for some people - after follow me (or any guided mode) flying, you may not be able to control the tilt of your camera gimbal. The “fix” is to reboot your Android device. See this thread: … r-connects

The angle of your antennas makes a big difference for reception. Do NOT point your antenna directly at the Iris+ - that will result in a weak signal. The antennas broadcast out sideways, so ideally you want your antenna to be parallel with the antenna on the Iris+ (which should be pointed down toward the ground). Actually, they broadcast in kind of a cone shape from the sides of your antenna. There is a dead zone in th middle where the tip of your antenna points. You will find that when the Iris+ is directly above your head, you have a weak signal because you are in the “dead” zone of the Iris+ antenna (Assuming it is pointed down as recommend).

There is a thread over on DIYDrones about landing. Can’t find the link right now. Here is the summary:

When you land, keep your throttle straight down for several seconds. Sometimes it takes awhile, but eventually you will hear the motors spin down. Once you hear that, then you can disarm (move throttle down and left).

If you try to disarm before you hear the motors slow down, then the Iris+ might try to yaw, which can result in a flip over.

I’ve heard they are going to try to improve this (or already did) in the latest firmware, but I have not tested it.

Really appreciate this thead, Gino, This discussion should help when I get a chance to fly mine the first time. No idea when that will be… It should be getting to be flying weather here, now, but instead it is snow storm one day, deep freeze the next few days, ice storm… then rinse and repeat.

I do not know which version of APM I currently have on IRIS+.
Which is a way to check ?

Anyway I will follow the advice of ISERIES and will try to update to 3.2.1

This should fix the LAND problem. Also, I have read elsewhere that “follow me” was introduced with version 3.2.
So if my APM is earlier, it can not follow me at all !!!
I will let you know…


I don’t know exactly which version I have but the first time I powered up and connected Iris it prompted me to install an update, which I did.

If you have an Iris+ it can do follow-me. All of them support follow-me.

Regarding firmware, just connect with Mission Planner (or APM Planner on the Mac) to check. Most likely you have 3.2 unless you bought your Iris+ very recently in which case you might have 3.2.1


I have finally made the update to 3.2.1, then a short fly in the courtyard, as I had to check my new Gimbal. You can see it here:

next weekend maybe I could try “follow me” again.