INS: Unable to Initialise Driver Error - MambaF405 Mk2 - 4.1.5 Really Need Help

image

NOTE: this shows us having v4.2.0 installed, but we tried the stable versions as well, 4.1.5 and it doesn’t work either.

Running into this issue where we have the MambaF405v2 version of Ardupilot (tried both the .hex and.apj) installed onto our mamba f405 mk 2 fc, but we are constantly getting this error:
INS: Unable to Initialise Driver Error
It can read our parameters, so we can change things, but we can’t figure this out.

Any help would be appreciated

Did it ever work do you know? If it did then knowing which version would help

It had worked at one point, on 4.1.3 I believe, but we had to temporarily flash it to betaflight for a servo test. Upon flashing it back to Arducopter 4.1.5, the INS: unable to initialise driver error showed up. We have tried flashing many different versions of Arducopter, including 4.1.3, for the MambaF405V2, thru the hex files and apj files (stm32cubeProgrammer and mission planner configurators), including 4.1.0 through 4.1.5, beta, and dev versions, as well as MambaF405v2-heli (idk how this one is different from the non heli version but we tried it anyway).
But the error shows up every time, other forums say it’s a firmware issue, but no version/ flashing method we choose seems to work, in terms of not giving us this error. Could a parameter within the INS categories be the issue?

Does betaflight recognize the IMU?

I think so, We can tip and rotate the board in betaflight with betaflight flashed on it and it recognizes the movement of the board on the main screen. Is there another way to verify if it recognizes it?

In bf confgurator there are some sensor icons at the top that get highlighted

The sensor icons, accelerometer and gyro are higlighted, yes

Not sure how to help you further, I don’t have access to this board. I think I saw something similar when I had a short on one build.

Well in between it working and now, where it’s not working, we did add a bunch of new solder connections, maybe one of them is bad? I will desolder and clean them up and see if that works.

-Thanks