Indication about 'arming' state of the my PIXHAWK does not appear in the MP

for some reason, I do not see the arming state any more on my MP screen.
I would like to have the indication, if the plane is armed or not.

I have the parameters ARMING_CHECK and ARMING_REQUIRE set to 0, but I had it also before, so I do not know if this influences the fact, that no indication about the arming state is delivered.

Some ideas?

ARMING_CHECK lets your arm the plane only when all the checks are passed. ARMING_REQUIRE sets whether arming is required in the plane. They decide if you can control the motor in your plane. If you have both set to zero, that means your aircraft does not need to be armed because it already is. For safety, I’d recommend you to enable ARMING_REQUIRE. That could be why you aren’t seeing the status on MP.

When the plane is disarmed, You can see the LEDs blinking on the pixhawk. On mission planner, IIRC, It should say “Disarmed” or '(Safe)". When you arm the aircraft through MP, You should see that message ARMED. It won’t stay for long though.

What confuses me, is that in an older pixhawk I have (which I did not setup, i bought it RTF from some guy - should be v.3.4) both parameters are set to zero, but still the word DISARMED and ARMED appear in the MP.

Another thing which is confusing me a bit, is that even if I have the two parameters set to zero, I still have to physically arm the plane using the safety switch. Before that, all outputs are dead.

So, did I understand it correctly, that we can have 1 or 2 arming steps? 1: when ARMING_REQUIRE = 0, we have the arming through the safety switch, once armed, everything is armed, i.e. servo outputs and motor! 2: With ARMING_REQUIRE=1 we can arm the servos with the safety switch, but motor is still ‘offline’ until it is additionally armed via MP or the remote control if respectively setup.

But again the question, why do I have the arming indication in the old pixhawk although ARMING_REQUIRE = 0 but not in the new one v.3.7?


Yes, This has always been a two step process as far as I can recall. You can disable the use of the hardware switch by changing the BRD_SAFETY_ENABLE parameter.

About the arming indication in 3.7, I can’t think of anything else that could be the issue