In ArduPlane-2.76 SITL, servo out link does not work

i make ArduPlane-2.76 sitl with cygwin on windows 7 32bit and i can build just fine. i run and connect with MP without any problem. GPS is 3Dfix and i can see pwm value changes by control with joystick. but in Simulation window of MP, i can’t see any servo out changes in graph. also in X-Plane i can’t see any change of control surface. So i cannot control plane at all. i think the problem is in sitl pwm timer. where can i start to fix that.

Hi Vincent,

Is your problem solved. I don’t why there isn’t support regarding SITL here not on DIY drones as well. Aren’t there people using SITL ? Even I am stuck at either connecting Flight gear or Xplane to see the out put of Mission Planner. I have a working setup of flying a Rascal plane in SITL with ArduPlane firmware and I am able to see the output in Mission Planner and I can change the parameter from Mission Planner as well, I just can’t connect to Xplane or Flight Gear.

Let me know if you are able to run the simulation with ll of these connected.

It is most likely that MissionPlanner isn’t sending the right packets on the SITL socket interface. Maybe ask on the MissionPlanner forum?
I use SITL all the time on Linux. If you get really stuck you can download a Linux virtual machine and run it in that.
Cheers, Tridge
PS: yes, we should improve the instructions for SITL on windows!

I’m also looking for setting up SITL… I agree, info for Windows setup would need some addition. That is not a complain. :slight_smile: But I have a some questions… Can I use the Beagle Bone Black collecting dust at the moment for the Unix system? or I should build a Unix Server using a PC… also collecting dust? I would also like to confirm that X-Plane will work with SITL? and what GCS should I use? I have a good experience with HIL and APM2.5 and Mission Planner… but SITL is very new to me…

…I guess that i’m stuck here… Seriously, I switch to PixHawk to move on… but I lost HIL… pretty sad… can’t pretend to fly anymore… help? anyone…?

Vincent. I don’t want to hijack your post… I hope you understand.