Impossible takeoff flyaway ended in crash

I had two sessions of Autotuning today.
The first tuning the roll and the second for pitch went well without any problems,
however, after the second autotune procedure, I disarmed the quad and disconnected the battery.
I have re-connected the battery to test the new settings, and pressed the safety switch.
During its startup I heard the oh oh sound and looked in the QGC it complaint about need 3d fix, which was reasonable.
All that time I didn’t notice that my radio’ Autotune mode was still on and AP didn;t mention anything about the mode. (logs doesn’t show that either).
So, I armed with my sticks and pushed the throttle, motors reved up as they should, however at about 30cm or so the quad started to fly away from me.

I was able to take control with the stick without changing any mode and tried to bring it back to land, however, the quad started a toilet bowl in the air but very close to the ground, so I was able to semi landing/crashing it slowly.

I am truly lost here, how is it possible to arm if Autotune mode is enable? Why there is no mention of it in the logs (i turned the mode off in radio after the crash)? also, I might have touched the pitch stick but I am not sure that I did, however I am not yet savvy in the world of logs to analyze what went wrong.

So it is an X8 coaxial
Cube Black
4.0.2 fw

Any help would be appreciated.

Is there something different with Motor 1 and 8? 1 is high and 8 is low.

I would have expected to see all the motors around the same value for a hover

When was the last time the ESCs were calibrated? Has any changes been done since they were calibrated last?

Hi Dave, not that I know of motors . same motors, same 16" props (the ESC are can bus so it doesn’t need calibration as far as I know). I would expect that too I guess, however, maybe it is the effect of motor

Did you try taking off again with the autotune turned off? Were you able to see what settings were saved in MP?

No I did not, one of the props broke and I didn’t have a replacement.
here are the diffs of the two Autotunes which clearly shows that params has changed in each of the procedures.

here are the actual param files
before first AT params
before second AT (result of roll AT) params
after pitch AT params


To clarify a few things:

  • the vehicle was in PosHold mode (not AutoTune). As you say, it’s not possible to arm in AutoTune mode.

  • I agree with @smartdave that there is a significant motor imbalance on this vehicle. The normal acceptable limit is about 150pwm between the highest and lowest motors but in this case it looks like it’s 300pwm. There are many possible causes but to name a few:

    • bad center-of-gravity
    • ESC calibration required
    • one or more motors are tilted
    • a motor/propeller is spinning in the wrong direction (unlikely)

Vehicle circling (aka “Toiletbowling”) is normally caused by a bad heading. Normally this is caused by interference on the compass from the motors and this is certainly true for Compass1 and 2 but I see the primary has been set to compass3 which looks ok. It might be good to set COMPASS_USE and COMPASS_USE2 to 0 to stop the other two compasses from ever being used. I’m not sure this is the source of the heading error though.

Hi @rmackay9 @smartdave ,
Thank you for taking a look and your clarifications.

  1. In regards to the Autotune mode being enabled, I have verified the scenario I have mentioned by enabling logging when disarmed (log here). when the fc boots and notice that the channel 7 is high it will raise the error “Flight-Mode Auto tune refused” and continues as usual. Now I am not sure if it is by design but from that point onward the fc ignores that channel completely which makes me wonder, why should it ignore it when arming? At least to me it makes sense that when arming and Autotune channel is in high fc should refuse arming.
  2. I thought that CAN ESC’s doesn’t need caliberation, so I guess it was a mistake?