Servers by jDrones

I'm a bit lost with skid steering setup. Please, advise


(Sazabi) #1

Hi, everyone. Just few questions about skid steer setup, because I’m not sure I’m doing it right.
What I want: I want to control my tank style platform in a tanks style way. One rc control stick controls left track, another stick controls right track. My setup: RC control unit (planty of channels), tank-style platform.
I’ve made setup according to Rover 3.2 guide for skid steering. Param PILOT_STEER_TYPE set to 1, SERVO1_FUNCTION set to 73, SERVO3_FUNCTION set to 74.
What I got with such params:

  • (I’m using servos for testing) left stick all way down, right stick in middle, ch1out 1500, ch3out 1500.
  • both stick in middle, ch1out 1400, ch3out 1800.
  • left stick all way up, right stick in middle, ch1out 1360, ch3out 1900.
  • right stick all way up, left stick in middle, ch1out 1900, ch3out 1580.
  • right stick all way down, left stick in middle, ch1out 1100, ch3out 1740. With a sudden peak on both channels to opposite side.
    So both servos react on each control stick. And as I understand tank control, each stick for each servo, right?
    I know it’s 3.2 thread, but I’ve tried 3.1.1 also and it behaves way better.
    I put both params SKID_STEER_IN and SKID_STEER_OUT to 1 (first for RC tank control, second for tank style platform). But doesnt seems like SKID_STEER_IN affects on anything.
    With this params control is way more adequate than in 3.2. Ranges are much bigger. No sudden peak jumps in signal. Here’s what I got:
  • left stick all way down, right stick in middle, ch1out 1100, ch3out 1100.
  • both stick in middle, ch1out 1500, ch3out 1500.
  • left stick all way up, right stick in middle, ch1out 1900, ch3out 1900.
  • right stick all way up, left stick in middle, ch1out 1750, ch3out 1240.
  • right stick all way down, left stick in middle, ch1out 1240, ch3out 1750.
    So yes, it control, but not the way tank controls:) Still, one stick controlls throttle of both sides, and another just accelerate/decelerate motors for turns.
    Is there a mixer somewhere I am missing to change? My RC has no mixers, each channel in independent.

Addition. I’ve missed, that only one SKID param should be set. So now it works as intended. Anyway, 3.2.0 FW doesn’t work as it should with a skid control.


(Khancyr) #2

Hello,

Thanks for reporting that, it may be broken, we will look at it !


(Tim Worley) #3

Sazabi

I have been messing with this same issue for a month now. I am basically seeing the same thing. No matter what I do I can not get the Tank Steer function to work. I am always getting throttle on the left stick and steering on the right. Hopefully someone will figure this out.


(Sazabi) #4

Haven’t tested latest FW since than. But for previous FW, you need to activate only one option, as guide states. I’ve missed that at first. But than it worked ok.


(rmackay9) #5

The skid control has been pretty well tested in Rover-3.2 so I’m pretty confident that all the basic stuff is working. I could be wrong of course but in either case I’m happy to help work through the issues you’re seeing. Could you provide a dataflash log?


(Sebastian Schürmann) #6

Hi Randy, I also found PILOT_STEER_TYPE 1 not working as expected in 3.2.1. I set everything up as described in the wiki. Input on channel 1 and 3, output also on channel 1 (left wheel) and channel 3 (right wheel).
Input goes from 1000-1500-2000us and output from 1200-1500-1800us.
If I raise channel 1 to 2000us, I get 1800us on output 1 and 1400us on output 3, causing the right wheel to turn backwards. The opposite happens, if channel 3 is raised to 2000us. The same goes for lowering channel 1 or channel 3, the channel that should not be affected gets 100us in the opposite direction (1200 and 1600us). If I set output 1 and 3 to passthrough, I can control both wheels seperatly.


(rmackay9) #7

Sebastian,

You are absolutely right! Thanks for finding that. I’ve pushed a fix to master so it will certainly go out with Rover-3.3. We might push it out earlier if we do another patch release - there is already a patch release in beta testing (which does not include this fix) but I’m not sure if anyone has tested it yet.

In any case, you can test if this fixes the problem by opening Mission Planner’s Install firmware screen, press Ctrl-Q and the version displayed under the Rover icon should be “ArduRover V3.3.0-dev”. Press the rover icon to install. Note: it takes a couple of hours to build the firmware on our centralised server so only do this a couple of hours from now.


(Sebastian Schürmann) #8

Thanks for the quick fix. I was too impatient to wait for the build server, so I have built ardurover 3.3 myself.
Will test it as the lipos are recharged.


(Sebastian Schürmann) #9

PILOT_STEER_TYPE 1 is working now! Thank you, Randy!