How to unbrick Pixhawk?

After discovering this:
I proceeded to flash using Mission Planner for windows in VmWare.
It ereased, flashed for a while, then status changed to some serial timeout error, and a msg box asked me to unplug, and replug USB.

I see USB device 26ac:0011 when connected
So - How can I enter a backup bootloader or similar recovery solution ?

Does the Pixhawk make any sounds when you try to load firmware?

The other day I was flashing the firmware and the connection timed / computer froze out while it was erasing. I tried to reset power on the pixhawk, unplug and replug the USB multiple times but the Pixhawk didn’t make any sounds when I tried to boot.

In order to fix the problem, I held down the little reset button on the side of the Pixhawk and added power while holding down the button. You will need to get a pin or something small to push the button. I believe it reloads the firmware from EEPROM.

After that I was able to hear the startup sound when booting. I re-ran the Mission Planner wizard and made sure I had the right firmware installed. You can listen to the pixhawk startup sounds here:

no, mine does not make any sounds now.
right after the original “crash” and until I actually tried to hold (one at a time) switches in while booting, random noise were output to the beeper.

I were able to reflash, no magic, just few retries.