How to setup arducopter to gradually switch into RTL mode

I am using a hexacopter and when I switch from auto to RTL mode the hexacopter jerks midair my best guess is that as soon as i pressed RTL, which as at lower speed than wpnav speed, the momentum of the drone carried it forward while fc was trying to pull it in other direction. The RTL speed is 3m/s and wpnav speed is 7m/s. Is there any parameter that can be set so that RTL speed is reached gradually instead of sudden change in speed.

I suspect that RTL uses the Loiter controller so you might be able to adjust some Loiter params (or not)
Otherwise set the RTL speed closer to the WPNAV speed.
RTL should definitely be your most efficient speed for maximum battery conservation, considering a RTL may be triggered by low battery. And maybe WPNAV speed should be too, to give longest flight time, unless there’s a need for a particular WPNAV speed.