How to scale down max motors power

I build 7 inch quad based on old DJI snail escs/motors powered by 4s battery. The total starting weight is less then 700grams. When i try to run in acro mode in my hand it’s quick oscillating due to too high P term. Reducing P term below suggested minimum =3.0 to 2.0 does not help much :frowning:
I was also trying to set up MOT_PWM_MAX = 1800 but i can’t arm due to parameters error (why?)
When i powering quad using 3s pack, it acts much much better, so it means, that it over powered…
Total thrust of 4 motors is like 6kg :slight_smile:
What is save way to limit max power, or maybe not limit but scale …
Can i go with P term below 2 ?
Thank you in advance


Yes, no problem to go with P term below 2. Just decrease small step by small step.
Your issue really looks like a PID issue and I have never heard about similar issues caused by “over powered” propulsion system.

Maybe you can check logs, comparing pitch/roll/yaw with DES_pitch/roll/yaw ?

I can’t help you about MOT_PWM_MAX = 1800 causing parameter error… Maybe you can’t go below 1850 ? But I doubt that…

6kg thrust for 0.7kg AUW is… HUGE ! Are you sure ??


Thank you for your feedback.
I will try today later, with lower pids and logging.
Regarding thrust, the single DJI snail motor with 7 inch prop powered by 3s bat according to DJI gives more then 1100 grams of thrust. I’m powering it from 4s, and according my measurements, it gives more then 1500 grams of thrust… So max total 4 * 1.5 = 6kg.

Finally i figure out that, it’s more connected to roll/pitch rate then to stab pid.

For such a settings, there is no oscillations, when quad is in my hand, the problem is that less then 20% throttle is enough to lift it …
I also wonder about such a small D term. Increasing it to 0.002 introduces oscillations…

1 Like

1 Like

Finally I managed to tune it, and it seems to be flying quite good. I used 4s2p battery to make it heavy, and now about 30% of throttle is enough to hoover.
New settings looks like following:

And i only wonder why D term is so small. When i inrease it to 0.002 UAV starts shaking in acro mode.
I can’t judge (cause lack of experience) if logs looks good, but quad is stable in all modes…

I also wonder why in acro mode it does not hold roll/pitch angle, but trying to level… But this levelling is not such a good as in stab mode… Maybe I term is too low…
What do you think…
Thank you in advance
And it looks like below :slight_smile:

What is the INS_GYRO_FILTER set to?

It’s set to 20.

Try 60. Default isn’t typically appropriate for a 7”craft. Also set the Rate pitch and Roll filters to 30. Then start over with the PID tuning.

Hit Alt>A in Mission Planner to launch the tuner script.

Thank you.
I will try

One question, do you mean this filters ?

“I also wonder why in acro mode it does not hold roll/pitch angle, but trying to level”

Try to make the P and the I to the same amount. 0.020 in your case.
After Autotune they are always the same

And what you discripe is a typical I problem

Thank you.
Will try.

Yes, and the FLTT, same value. Try just the gyro filter first to see if the oscillation goes away.

ok, thank you for all your help.
Try setting ACRO_TRAINER,0

Yes, thats true. I never think about that because it’s the first thing I do.

Thank’s i was not aware that default may be different then 0.
Will check it.

It’s me again.
After 2nd tour of tuning increasing gyro filter to 60 and ATC_RAT_PIT/RRL_FLT to 30 i was able to increase D to 0.002 but not more, because of oscillation.
So no it looks like following

It’s quite ok, but still I can hear some kind of osculation, and footage taken by rigid mounted camera shows some problems in roll at very left/right part of movie frame.
You can see/hear it at uploaded video…

I know, that it’s better to use soft mounted camera, but first i want to make as much as possible with tuning.
What else should be done?
Thank you in advance