How to make copter stop at wp, change yaw, and only then move to next wp?

I know you can set a second waypoint very close and a delay to do that, but that becomes impractical when using the grid survey option.Is there a parameter or something that does this?

1 Like

So WP_YAW_BEHAVIOR=1 isn’t enough for the job?
If it is not enough than I have an idea.
In this mission item set the time field which is the first parameter to zero or some little seconds.
Second parameter which is the heading required parameter, set it to 1.
You can try it.

I am using wp_yaw_behavior=1 , but that doesn’t stop the drone at wp. I will try the other option

That’s the expected behavior. Try the loiter time with heading required = 1

Are you using ArduCopter 4.1.0 or 4.1.1-rc1 ?

I am using 4.1.0 beta-5