How to keep ArduCopter on track (not blow off course) in windy conditions?

Hello fellow copterers!
I am using a modified 4.0.5 Copter (general copter behavior is stock, mods are other custom functionality) to perform surveys, collecting magnetometer data.

In order to get good data my passes need to be straight lines (or as much as possible).
I noticed however, that my vehicle gets affected by the wind and is often travelling up to 1m from the line it is supposed to maintain.

Is there a gain parameter or something like that which specifies how aggressively to correct for position error?

Right after I posted this I found the PSC_POSXY_P parameter. Currently set to 1.0. Range is up to 2.0.
I will crank it up and see how it affects things.

ArduCopter 4.2.3 has ground tracking improvements that help you achieve that.

Use git to rebase your changes on top of the Copter-4.2 branch and recompile it.

1 Like

There are many factors that could cause this behaviour… even bad tuned attitude controller can cause it. Also check for a good RTK GPS in order to improve position accuracy.

Just an update, increasing the gain did help.

Thank you for the help!