How to connect PH 2.1 and Edison

Hi, there.

I get PH2.1 compatible Intel Edison.
The Cube in PH2.1 installed APM Copter v3.5.5 and set SERIAL2_PROTOCAL, _BAUD and LOG_BACKEND_TYPE(ref
Edison installed APSync 3.10.17-yocto-std

But, in Edison don’t running.
This is shown Error Message “Bus Error”.
I checked netstat, this is not run 14655 port!

I want to use MAVLink and PH-Edison Comm.

What screens are listed under “screen -r”?

Try just running “mavproxy --master :14550”

“screen -r” listed DataFlashLogger and cmavnode

Try running “ --master:14550”, I saw same error “Bus error”

You need a space there.

Same error.
Command “ --master :14550” and in directory “~/” show same errors. is built in script

Ok, that’s really strange.

What does “screen -list” show?

Also, what’s “df -H /” give?

There are screens on:
327.DataFlashLogger (01/01/00 00:00:17) (Detached)
300.cmavnode (01/01/00 00:00:17) (Detached)
2 Sockets in /var/run/screen/S-apsync.

Filesystem Size Used Avail Use% Mounted on
/dev/root 1.6G 1.6G 0 100% /
devtmpfs 504M 0 504M 0% /dev
tmpfs 504M 0 504M 0% /dev/shm
tmpfs 504M 14M 491M 3% /run
tmpfs 5.3M 0 5.3M 0% /run/lock
tmpfs 504M 0 504M 0% /sys/fs/cgroup
/dev/mmcblk0p7 6.2M 5.7M 469k 93% /boot
/dev/mmcblk0p10 1.4G 479M 876M 36% /home
tmpfs 101M 0 101M 0% /run/user/1001

Oh, Why my rootfs is full?

Run “fdisk -l” show
GPT PMBR size mismatch (7634944 != 7634943) will be corrected by w(rite).

Disk /dev/mmcblk0: 3.7 GiB, 3909091328 bytes, 7634944 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 21200400-0804-0146-9DCC-A8C51255994F

Device Start End Sectors Size Type
/dev/mmcblk0p1 2048 6143 4096 2M Microsoft basic data
/dev/mmcblk0p2 6144 8191 2048 1M Microsoft basic data
/dev/mmcblk0p3 8192 12287 4096 2M Microsoft basic data
/dev/mmcblk0p4 12288 14335 2048 1M Microsoft basic data
/dev/mmcblk0p5 14336 16383 2048 1M Microsoft basic data
/dev/mmcblk0p6 16384 65535 49152 24M Microsoft basic data
/dev/mmcblk0p7 65536 131071 65536 32M Microsoft basic data
/dev/mmcblk0p8 131072 3276799 3145728 1.5G Microsoft basic data
/dev/mmcblk0p9 3276800 4849663 1572864 768M Microsoft basic data
/dev/mmcblk0p10 4849664 7634910 2785247 1.3G Microsoft basic data

My Edison’s eMMC is strange…

Yep. Hunt around and free some space and see if it helps?

I find trash point that is log file.
but I don’t know this log…

kern.log, message, syslog in directory "/var/log"
Jan 1 00:11:51 localhost kernel: [ 703.729605] HSU serial 0000:00:04.2: Got LSR irq(0xf8) while using DMA

And, It’s not solution :frowning:
I was deleted log file and get 200MB free storage in rootfs.
Now rootfs’ space used 100%, too.

What HSU Serial is?

I assume some sort of serial hardware on the Edison.

Probably something like

systemctl disable rsyslog

Hello, Did you have a good weekend?
I success in running mavproxy.
You are right.
The reason was that no free space in the storage.

Thank you, Peterbarker! :grin:
Have a nice week.

Great, thanks!

I’ll stare at the next Edison image hard to ensure as much free space is
available on the image.

I delete /var/log and created a symlink to /home/log, that way the logs accumulate on a different partition

mkdir /home/log
rm -rf /var/log
ln -sf /home/log /var/log

Thanks! I’ll consider doing that on the next image. Should also analyse
why the logs are getting large.

Thanks for this!

I had the same issue, and this seems to resolve it for now.

1 Like