Servers by jDrones

How to change auto takeoff settings?

Hi guys.

I really like how my Pixhawk Black Cube with 4.0.2 is flying, but I am having some problems with auto take off. When I press the takeoff button the motors spool up real fast and the drone shoots straight up really fast to about 8-10 feet and then slowly climbs nicely to 10m. I cannot find anywhere in the parameters how to change the ramp time of the motors, how to change how fast the motors spin before it takes off and I even cannot find how to change the takeoff altitude? Can anyone help me please? The motors seem to go from zero to full throttle on the ground in 1 second and then it launches so fast straight up and then settles down. What parameters can I change? Thank you very much.

Auto Takeoff? What Takeoff button?

Hi Dave.

I am running the Herelink controller and it uses QGround Control. There is a RTL and a Takeoff button on the left side of the screen…I do it in Loiter Mode.

Ah OK. I’m not familiar with those features. Is it running Arducopter or PX4?

I am running Ardrucopter 4.0.2.

I have been looking around the internet and I am not sure there are takeoff settings? Should be at least a takeoff altitude I would imagine. Anyone? Thank you.

The only takeoff setting’s I’m aware in Arducopter are for the Takeoff command in an Auto mission. And that’s a mission command option not a parameter.

Ok, thank you Dave. Weird they would not have in advanced parameters or at least to be able to change the altitude. I think the understanding is to get it off the skids and ground effect fast, but it would be nice to be able to change it always going to 30 feet. I will do it when I flight plan a mission.

you might check on cubepilot.org forum where they talk all about the Here link. I havent tried the auto take off function yet.

There’s this, but I’m not sure that it’s related:
https://ardupilot.org/copter/docs/parameters.html#pilot-tkoff-alt-pilot-takeoff-altitude

1 Like

Good point, I didn’t consider that feature. I wonder though if in this case it’s the Herelink sending mavlink commands. I suppose he will know if the PILOT_TKOFF_ALT parameters is still at default (0).

Servers by jDrones