How to build ArduPlane with library target for Pixhawk and view serial output

I am new to using arudplane and have been successful uploading the firmware to a Pixhawk 4 using ./waf and connecting to Mission Planner. Now I was following the tutorial on the wiki explaining how to build an example library and I haven’t been able to get that to work.

I run the commands in a windows linux terminal:
$ ./waf configure --board=Pixhawk4
$ ./waf build --target examples/INS_generic --upload

and the build seems to execute successfully and ends with the output

Build commands will be stored in build/Pixhawk4/compile_commands.json
‘build’ finished successfully (3m39.033s)

However, when I try to connect to a serial terminal on PuTTY (COM9, 57600) to view the output it fails to connect. I have also tried mavproxy with the command

$ --master=/dev/ttyS1 --baudrate 57600 --setup

and the output that I get is

Connect /dev/ttyS1 source_system=255
Log Directory:
Telemetry log: mav.tlog

and no other output, not the output of the library that I was expecting. Additionally, in case its relevant, when I try to run

$ --master=/dev/ttyS1

I get the output

Connect /dev/ttyS1 source_system=255
Log Directory:
Telemetry log: mav.tlog
Waiting for heartbeat from /dev/ttyS1
MAV> link 1 down


Doesn’t seem like that is working either. Any ideas what I am doing wrong? Thanks