How Do I Install APMRover 2 in Pixhawk 2


We have tried to install APMrover2 with Mission Planner and Ubuntu terminal on using make Pixhawk2 with no success. Has anyone installed APMRover2 firmware on a Pixhawk2?


Jose L. Orozco

Are you sure that you have a Pixhawk2 and not a Pixhawk1?

Sir, Yes, we took it out of a 3DR Solo. We needed one and the prices were going down on the 3DR Solo so we bought one and took it apart. It is a cube.

1 Like

I have - works fine. Mission Planner should detect it correctly. Let me know if you have any problems.

Thanks, Grant.

Grant, Did you use it with the Solo board or the Pixhawk 2 board?

I’ve done it with both through Mission Planner installing the stable firmware and both work. Try that and if it doesn’t work let me know.

Thanks, Grant.

Actually I do have a problem with the Solo PH2. It seems to upload ok but when I reboot its not working. The lights go out after a little while and I get only half way through the musical tones. I uploaded the Plane firmware through Mission Planner and that worked fine. I’ll investigate.

Hmmm but I can connect to it ok through Mission Planner and it seems to be working ok. Weird.

Thanks, Grant.

To clarify the lights don’t seem to work properly and the musical tones are a bit weird but I got the firmware onto the Solo Pixhawk Cube ok through Mission Planner and it seems to be working fine. Let me know what you find.

Thanks, Grant.

I’ve been advised that the lights not being on is a feature. Apparently they interfere with the compasses so they are simply turned off.

So for me its all working. Let me know how you get on.

Thanks, Grant.

The lights are off by design