How can I set a GPS without auto configurate

when I connect GPS BN880,BN280,etc. with FC(matek405wing, 764wing,743wing,omnibus,F4V3pro,etc). it always has the auto config setup. the GC on the computer or the radio yaapu screen showes gps auto config saved…gps baud 230400…it never changes. even I set the gps with 57600,38600 by u-center app. it alwasys go back to 230400 at the next power cycle. even I turn gps auto configurate to 0. it still remain the same. can anyone tell me how can I set GPS to other baud? thank you

You must set the settings you want from U-Center. In Ardupilot disable autoconfiguration and autosave.

If you allow me I will give you some good advice that I experienced with a BN-880Q.

To maintain a frequency of 5Hz (200ms) you can only use 2 constellations together with SBAS. 1 constellation allows 10Hz and 3 constellations 1Hz.

However every 20 seconds there is a spike in GPA.DELTA. After many turns I discovered that it is a problem with the fucking 230400 bauds. The solution is to set from U-Center to 115200.

Another good tip is to disable NMEA messages and stay as pure Ublox.

I use 2 constellations and now it works well, I remind you that until you change the baud you will have peaks every 20 seconds.

thank you for your replies

looks like it is still autosetting my gps even I turned off autoconfig and autosave. is it possible to send your param file that I can look into to find whatelse I should alter.

Here the GPS params


it still autoconfig to 230400. even I disabled autoconfig and atuo save. all the params are same as you gave.

I repeat: “You must set the settings you want from U-Center.”

Disable autoconfigure and autosave first and reboot the autopilot. Then use uCenter to set what you desire, and be sure to save those settings to flash.


What I enclose are “notes” that I was compiling about the configuration of the BN-880Q. IT IS NOT A GUIDE TO FOLLOW TO THE LETTER. But in those notes is all the information needed to set up the BN-880Q.

*10. If you have satellites then your GPS is working fine and we can edit some important settings.*
*Press CTRL+F9 on u-center. a configuration screen will open.*
*Go to PRT (Ports) - The target should be UART1. Protocol in = 0+1+2. protocol output = 0+1. Change the bounce rate to 38400. Click the Submit button in the bottom left corner.*
*Go to RATE - Change the measurement period to 250ms. Click the Submit button in the lower left corner.*
*Go to MSG (Messages): Make sure the UART1 box is checked. If not, turn it on. check the box. Click the Submit button in the lower left corner.*
*Go to CFG (settings): check "Save Current Settings" and then click the Submit button in the lower left corner.*
*Disconnect the GPS from the PC.*

*Make sure that the protocol version and generation is M8 with 2.01 firmware (not sure how to check what firmware I have)*

*Press F9 in u-center. a settings screen will open. (CTRL+F9 but f9 allows right click on NMEA)*

*Go to PRT (Ports) - Target should be UART1. Protocol in = 0+1+2. protocol out = 0+1. Change boud rate to 38400.*

*Click the Send button in the down-left corner.*

*Go to RATE (Rates) - Change measurement period to 250ms.*

*Click the Send button in the down-left corner.*

*Go to MSG (Messages) - make sure the UART1 box is checked. If not, turn it on. check the box.*

*Click the Send button in the down-left corner.*

*Go to Nav5 / Min SV Elevation should be on 5 deg*

*Turn off NMEA messages (Messages/click right NMEA /disable child messages)*

*Go to CFG (configuration) - Check the "Save current configuration" and then Click the Send button in the down-left corner.*

*Menu >Reciever >Actions and click Save Config.*

*Disconnect the GPS from PC.*

*I also set the rate to 200ms (5 Hz) in the "RATE" configuration view.*

*1 - Program the New GPS Module*

*Connect the GPS module to the USB adapter as shown in the photo - remember to connect RX to TX and TX to RX and note the switch settings.*
*Connect the adapter to a computer and open U-Center.*
*From the view menu select "Packet Console" this opens a window showing the data coming from the module. Depending on how good the signal is it should be getting a position and showing information in the boxes on the right.*
*Select "Messages" from the view menu. The dark items are active. Double clicking an item will enable or disable it.*
*Disable all the NMEA messages.*
*In the UBX Nav messages, activate the following*


*Next open "Configuration" in the view menu*
*Click on "Rate (Rates)" then set the "Measurement Period" to 200 ms*
*Click on "GNSS (GNSS Config)" and enable GPS, GLONASS, GALILEO and disable the rest.*
*Click on "PRT (Ports)" and set the baudrate to 57600*
*You may need to go to the Receiver menu and set the baudrate to 57600 to regain communication with the module and check it is still sending information.*

* *

*Here is my u-Center configurations:*

*View>Gen 9 Config View>GNSS Config*
*Enable only GPS L1 L2 & Galileo E1 E5b so chip is not overloaded with data that won’t get used*

*Protocol in: none*
*Protocol out: UBX (this is much more compact data than NMEA messages)*
*Baudrate: 115200*

*Protocol in: RTCM3*
*Protocol out: NMEA*
*Baudrate: 115200*

*No NMEA messages are turned on by default,*
*Message F0-00 NMEA GxGGA (GxGLL GxGSZ GxGSVG xRMC GxVTG, these were on but not needed?)*
*UART2: ON (all interfaces are on by default, can leave checked)*

*No UBX messages are turned on by default,*
*UART1: ON for the following messages*
*0A-09 MON-HW, 0A-0B MON-HW2, 01-04 NAV-DOP, 01-14 NAV-HPPOSLLH, 01-07 NAV-PVT, 01-03 NAV-STATUS.*
*(USB and other interfaces may be on, can leave checked)*

*Increase location resolving from 1/sec to 5/sec:*
*Measurement Frequency: 5 Hz*

*To view messages:*
*View>Messages>Right click on NMEA and UBX and enable*

1 Like

what is the difference for having item 0,1,2,4 to be blue colored. my gps does not save if it were only 0 and 1 color blue. it needs to be 0,1,2 or 0,1,2,4 blue colored.

@Yuri_Rage thank you for your help.

thank you for your remind. it works fine now.

I thought to change the param of the GPS thru mav serial pass. before disable the gps autoconfig and autosave…

thank you for such detailed explanation. I did as you said. it work now. it can get 14 sat by the window of indoor and it was nothing before. :+1: :+1: :+1: @Lano

one of my gps is SR2022U8. chips of M8030. it says I can use beidou, how to change it accordingly?