Holybro Telemetry Connection Problem

Hello everyone. I have a Holybro 915MHz telemetry for an autonomous flight. But I cannot connect to Mission Planner with this telemetry. The telemetry on the drone and connected to the computer is green. Doesn’t that mean they match? I can connect to the drone via USB but not via telemetry. How can I solve this problem?
Thanks in advance!

Good day, did you try connect with 57600?

Have a nice day. Yes, I tried on 57600, but unfortunately I could not get results. I was able to connect when I tried on another computer before. But now I’m connecting even though I tried it on two separate computers. First the red light flashes, it looks like there is data transmission, but then it turns green and I get the “timeout” error.

ok… check also pls the pinout on the telemetry module

1 Like

Thanks for your help Dave. I tried again today, reconnected the pinout and as a result I was able to connect! I still haven’t figured out where the problem originates from. But now it can connect!