Holybro Kopis 2.5 drone drifts a lot

I have a Holybro Kopis 2.5 with Holybro F9P RTK GPS and Kakute H7 Flight controller.
Unfortunately the drone drifts a lot and I am not sure how to solve the problem. Attached is a flight log which I can clearly see that even though I keep the drone on one spot in the air the position in the log varies significantly.

Can someone please help me and tell me how I could solve the problem? Would be really grateful for the help.


You solve the problem by improving the GPS reception and tuning the PID gains.

How can I improve the reception?
I use the following GPS model:
Holybro H-RTK F9P Helical, the module should have had clear view and it also runs with the latest firmware.

I have tuned the drone manually according to the Advanced Tuning Guide, because the drone drifts I have to hold it and I guess then I can not do autotuning or?

Without Advanced Tuning the drone was extremely unsteady and could not even take off properly.

Settings of the ESC

See Tuning Process Instructions — Copter documentation

I had determined the values according to the guide (2.5 inch props) and the drone takes off with the tuning also without problems, but drifts slightly to the side. Therefore, I can not let them fly alone at the moment. Therefore, I also do not know how I should tune the drone in flight.

That page explains:

  1. what needs to be done before autotune,
  2. and explains under which conditions an autotune can be performed,
  3. and finally how to perform an autotune.

I do not understand your question! Have you read the documents I sent you?

On a 2.5" you have to do more than the Initial Setup Parameters. The Motor outputs are oscillating like crazy:

First drop the Rate P&I parameters from default (.135) in half. And set these based on MOT_THST_HOVER as per the tuning guide:

Set this to 1 to collect data for the Dynamic Notch Filter which you will need:

Perform a short hover flight preferably in AltHold to learn a proper MOT_THST_HOVER value.

Thanks for the help.

I have first changed the default settings for the ESC, that the motors are controlled on a fixed PWM
These are also the original settings of the multicopter.
I also set up all the other parameters like: MOT_THST_HOVER

At the beginning, the drone had extremely wobbled at startup, I got with the settings from here under control:


Settings for 2.5 Props

After that, the drone was much smoother at takeoff.

After that I halved the default values:

But now again to the problem maybe I described it wrong. When I start the multicopter (in Stabilize) the multicopter rises and immediately starts to drift in one direction (drone drifts away sideways). I have no chance that the multicopter holds its position it always drifts.

Also as described I see that the motors are still a bit unsteady.

I just can’t understand why the multicopter can’t hold its position, that’s what it should do in stabilize?

What I also see is that the LAT/LOG values deviate massively from the real position (but that should not play a role in Stabilize).

No, Stabilize doesn’t hold position, your thumbs do… It only self-levels the roll and pitch axis.
Arducopter Flight Modes

So I would have to do the next section with Alt Hold, but then the multicopter goes completely into kamikaze mode and not only drifts but flies off to the side (When I hold the multicopter in the the multicopter pulls away massively in one direction). This probably tells me that somehow the sensors are disturbed GPS/compas. Problem is that I can’t really put the GPS anywhere else on the tiny multicopter.

That can happen with high levels of vibration. Although your previous log didn’t indicate that. Rather than that tuning guide Wiki did you run the Initial Parameter Setup in Mission Planners Mandatory Hardware section? It may produce similar results but worth following anyway.

And, you don’t have to run it in AltHold, just Hover in Stabilize as best you can. You can get hover throttle from the log Ctun>Tho.

Had determined the values peer hand according to the wiki:

The determined values from Mission Planner differ slightly from this.


Use those but keep the Accel Filter at 10Hz

That definitely helped a bit. After I flew in Stabilise I set the appropriate parameters:

The drone already drifts significantly less in AltMode. But it still doesn’t really hold its position. Will test again tomorrow how it looks when it has GPS.

The engines have also become somewhat quieter and also become much less warm (significantly).

The drone will only stop drifting when:

  • in loiter mode
  • full GPS locked
  • No trims on the RC transmitter
  • PIDs, autotuned.
1 Like

Read the Flight Mode link I posted. AltHold will only hold altitude and then only after it has learned the mid throttle position. That has not yet happened…

Thanks for the help so far. AltHold worked fine and I set the appropriate parameters afterwards.

Next I need to set the dynamic notch filter.

There I am not so sure about the choice what gives the best results.

I understand INS_HNTCH_MODE = 1 would be standard, but since I have a Tekko BLHeli32 ESC I could also use INS_HNTCH_MODE = 3. But as I understand the text INS_HNTCH_MODE = 4 would be the best choice.

Unfortunately I can’t find any info about how much flash the Kakute H7 has. Can someone tell me how much memory the H7 from Holybro has?

I have now tried according to the instructions to set the parameter FFT_ENABLE = 1 and made a flight in AltMode. But I wonder a little bit about the results of the FTN1.PkAvg.
As you can see in the section of the AltMode flight the frequency remains constant at 80 Hz.

The middle section where the line stays at 80 Hz was in AltHode mode.

Is there something wrong with the flight controller? Because the results look clearly different than described in the tutorial.

Flight Logs:


Would be very happy about a tip

Those links have an access requirement so… No Dice.