HIL Simlator failed to download new firmware

Tried the Plane-Simulator, while selecting 3.1.0 as firmware to load, I got an error:

Failed to download new firmware : System.UriFormatException: Ungültiger URI: Der URI ist leer
bei System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
bei System.Uri.ctor(String uriString)
bei System.Net.WebRequest.Create(String request UriString)
bei MissionPlanner.Utilities.Firmware.update(String comport,software temp, String historyhash) in c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Utilities\Firmare.cs: Zeile 511.

Tried some ther, none of the tested Plane-FW work, Got only one Copter-FW to load, but that is not what I need…

what board are you trying to upload to?

Pixhawk. Do you meen the Version? How do I know it?

Hi I can not also download the HIL simulation for pixhawk. I get the same error. I have attached the screenshot. I can however download the heli and quad HIL simulation but i have a plane set up (calmato 60 trainer).

Updated to the current Mp, the error remains. No ideas there?