Noob to cubepilot and ardupilot here… I have the Herelink controller system and a cubepilot orange with the here3 GPS all setup for a new build… i have gone through every single setup manual around and for whatever reason on my herelink controller with Qgroundcontrol i constantly get the message: Parameters are missing from firmware. You may be running a version of firmware QGC does not work correctly with or your firmware has a bug in it. Missing params: -1:COMPASS_PRIMARY

what could this possibly be i have the here 3 set up on can1 and in ardupilot its priority is 1. Im working on a massive quad with 29" props… i cant have questionable settings ya know lol

Try updating QGC. There is no bug because there is no COMPASS_PRIMARY parameter in Arducopter.

i dont think you can update QGC on herelink controller… i did whatever updates it asked for when i just took it out of the box.

Ah, sorry it’s GQC on the controller. Well, then I suppose you ignore that error. It’s giving an error for a parameter that doesn’t exist. QGC running on a Ground Station device (PC, Tablet, phone) does not give that error. Post in the Cubepilot forum.

1 Like

Hi Tyler, I’ve received the herelink and tried to connect it but there is still no video. Please correct me if I am wrong as I have connected it as follows:

  1. I am running ardupilot in my cubePilot.
  2. Connect 7v to the air unit.
  3. Connect the UART from the air unit to the telem1.
  4. Connect 5v to the cube.
  5. Connect gopro 3 camera to the air unit.
  6. in Ardupilot firmware, only set the baud rate t0 115200 and serial1 to 1 (mavlink)
  7. I’ve paired the air unit with the rc, the status is now paired.
  8. I’ve done the calibration for the RC.
    after doing all of that, there is no video stream. Can you help telling me what I am missing?