Here+ V2 problems


I purchased a here+ V2. It had been working fine, but recently, it stopped connecting with the flight controller. When connected, it appears to be getting power, but the lights don’t sync up with the controller. Instead, the lights stay a solid white and it doesn’t seem to be communicating with the flight controller. Does anyone have any experience with a similar problem?

what color it’s been glowing and did your drone had any bad crash?

the lights on the here+ glow a solid white, no blinking, and there was a recent crash but not too bad.

Did it work after the crash, or is that when the problem started?

before i understand the complete problem
possible fixes you can try are:

  1. try to use it with different flight controller
    2.Leds are synced with I2C port if it’s get damaged then also gps can work so check in mission planner if you are getting right location and no. of sats are greater than 10
    3.Check if the inside switch CAN or I2C is on I2C

it worked for a period after the crash, but started to malfunction shortly thereafter.

  1. I tried to use a different Here+ with the flight controller, and it worked fine, so I don’t believe it was the I2C port on the flight controller. It could be the Here+ port, however.
  2. We haven’t been getting any signal through the Here+ on MissionPlanner.
  3. The switch is on I2C.

Thanks for the help!

1 Like

I am afraid that your gps is dead can you see any physical signs of damage i also have a here+ which works fine at the very start and all of sudden stopped it also started to have strange pattern of leds and i noticed the temperature of the module is baking hot. What happened is that some wires are shorted which has made some damage although not visible but damaged internally

i have a problem from two weeks I am stuck with my here+ rtk . Actually I want to use external Barometer on my pixhawk2.4.8 .My problem is when I change the hardware switch to CAN mode my external compass is unable to detect,even no sign of barometer. I also saw whenever I change the hardware switch from I2C to CAN mode a bluish low rate blink starts. I am using new firmware 4.0.3