Here 2 compass is not calibrating


I have had a Here 2 GPS configured on my Heli with a Cube Orange. It was working fine but now it is showing compass not calibrated and double blinking yellow. I have tried to calibrate the compass in closed as well as an open environment. Also, I have done accelerometer calibration and then again tried to do compass calibration. But, so far, no success in getting the compass calibrated.
Additionally, I changed the compass and used Here 3 GPS for the calibration purpose and to my surprise, it is not getting calibrated too. (These Here 3 is working fine on my Hexacopter).

Is there something wrong with the cube firmware or I missed to set a parameter?

Your inputs will be a great help.

Thank You in advance.

What version of firmware are you using? When this issue first started, did it just appear between flights or did you change something (like move equipment on the heli, upgrade firmware or change settings) and then the error occurred.

Are you using both an internal and external compass or did you disable the internal.

Hi Bill,

Firmware Version - V4.0.3
The issue was identified for the first time during the flight.
Internal and External compass both are enabled, by default.

In order to share the accurate details with you, I just tried to fetch the dataflash logs. However, there are no logs saved in it. The parameter settings for saving the logs are all enabled (Crosschecked).

So, if you can share the information on dataflash logs too, that too would be great.

Thank You.

@Kdronz please update your firmware to the latest stable version which is 4.1.5. Retry your compass calibration. Most times only the external compass is used because of the potential for interference of the motor and other electrical systems with the one in the cube orange. You can deselect the use of the internal compass and redo your calibration.
Hopefully this helps.