Help with Failsafe connected via SBUS on Pixhawk

Hi Guys,
I need an help with the Taranis Radio Failsafe with an FrSky X8R…
Using Taranis with FW r2940
I’m in D16 mode. 1CH-CH8
I have ‘Custom’ set for the failsafe mode, and used the [Set] button to select my desired failsafe settings.
Monitoring the RX output (I’m using the SBUS), it seems to only hold the last received settings when I power off my transmitter. The receiver channels don’t go to the set positions.

I even tried to rebind the X8R to see if that would cause the custom FailSafe settings to stick. It doesn’t seem to be working. Am I doing something wrong?

I had exacty that same problem last week using S-Bus, and 18Mz and a R7008SB. I burned a couple of hours going through the following sequence with 3.15:

  1. Enable low throttle F/S
  2. Pick reasonable value (i.e. 940 usec)
  3. Draw down-throttle using end point adjustment on my 18Mz (and verified in the radio failsafe screen that the values were being drawn down)
  4. Captured that value as the F/S value on my transmitter
  5. Reset my radio endpoint back to -100% (so it couldn’t trigger the F/S, even at max low throttle).

Then the test should be simple, correct? Just turn off my 18Mz and the throttle would get pulled below 940 usec and I’d see it in the radio failsafe setting. But when I turned off the transmitter, the values persisted as if it were in perpetual “hold” mode.

So I tested it with 3.15 and a PPM encoder, using the same transmitter and receiver (but using the 3DR PPM encoder instead of the S-Bus connection). That failsafe procedure worked correctly.

So then I began to suspect a bug in how 3.15 processes S-Bus failures. I loaded the lasted beta 3.2-RC3 and tried the same 1-5 sequence above and it worked fine.

My best guess: Something needed a little cleanup regarding S-Bus failsafe processing in 3.15 and it has been done in at least 3.2-RC3 (if not sooner).

Hope this helps.


thanks for your answer, I’ll give you a feedback tomorrow I will have the chance to try it.

However I have on my Pixhawk Arducopter 3.2 rc2

I have done all this test with APM/Pixhawk disarmed and a friends on facebook have suggest to me to try the failsafe with APM/Pixhawk Armed because the APM/Pixhawk Monitor the channel 3 only when armed…

all the tests you’ve done … have you done it with APM/Pixhawk armed or disarmed? :question:

Let me know :wink:

It was disarmed during my tests, but the throttle channel (RC3) should have still dropped to below 940.

I’m having the same issue. Except I’m running 3.2 rev5 on my pixhawk. Throttle wont drop when tx shut off