Help with Compass Calibrations

I am having a super hard time calibrating my external compass. It is a Neo V2 Pro CAN compass.

I am not new to this compass as I have 4 others that work perfectly fine.

The CUAV Nano V5 compass calibrates just fine, but the external one no matter how many times I try.

I am however getting these messages and not 100% sure how to interpret them.

Mag(1) bad radius 385 expected 516
Mag(1) bad radius 371 expected 516

I was also getting a few of these:

4/20/2020 12:16:04 AM : PreArm: DCM Yaw inconsistent by 150 deg
4/20/2020 12:15:34 AM : PreArm: DCM Roll/Pitch inconsistent by 135 deg

I also tried by not Using the internal compass and just trying to calibrate the external.

Its possible that it could be hardware, but figured I would as this brains here first.



I just also plugged in my normal Neo V2 Gps Antenna and that calibrated right away. So I guess Hardware issue

First update the firmware .
2) calibrated compass in open area where no electronics are connect like backyard
3) set compass arrow in north direction
4 ) used different compass hardware in case if still error found .

Try calibrationg one compass at a time instead of multiple compasses at once.

I have tried to do them one at a time. My normal procedure is to disable the internal one and just work with the external. When that failed I started trying different things

Again I have 9 other crafts that do not exhibit this issue

1 Like

Just to 100% verify that it is the compass… I made a test jig and connected the GPS to a spare V5+ FC and tried to calibrate… Still no dice.

Maybe change to “relax” setting for calibration…and after that try to compass learn function during flight…

I have done that, plus change the offset max to 3000.

This compass is DOA, the replacement has already been shipped

Well the compass is broken, but the GPS is working fine.

I thought I would play around with GPS blending until my replacement comes in.

One CAN (the broken one) and one normal SPI/UART

1 Like