HELP NEEDED! Onboard compass doesn't work well for APM2.5

hello everyone, I have a problem for my APM2.5 with onboard compass. Before it worked well, but recently the horizontal line always shows oblique even the APM is leveled . I have also tried compass calibration, but after a few minutes it went the same.

Then I decided to use external compass, the one I am using now is UBlox GPS + Compass Module. According to the instruction, I have cut the trace on the APM2.5 board. But the weird thing is the onboard compass still works and works well after calibration. Does anyone know this problem?

Now, if I plug in the UBlox GPS + Compass Module, there is almost no corresponding response when move the module but the APM2.5 does. I have also changed parameter of COMPASS_EXTERNAL from 0 to 1, but still didn’t work.

And now it shows bad compass health, but the onboard compass is functioning .

So who can help me ? Thank you.

Sorry, my mistake. Just realized this is Accel’s problem. External compass is working now. But Accel still got the same problem after reassembling it . So this really help, thank you.

Hi bazooka270,

Try to repeat the accelerometer calibration again: … elerometer

If this is not working, check your board 3.3V regulator: … ed-problem

hi RogelioN,

Thank you for your help.

I have done many times Accel calibration, But it remains the same.

I also checked 3.3 voltage regulator and found it works well.

Now I have to manually set the AHRS_TRIM_X (for roll) and AHRS_TRIM_Y (for pitch) parameters directly in the Adv Parameters List in the mission planner. The weird thing is, sometimes, about 1 or 2 minutes after adjustment it goes tilted again by itself. But parameters didn’t change, in order to get it leveled, I have to increase or decrease the value.

So in this situation, it can not take off because not all propellers will spin or they spin at different speed.
Any suggestions ?

I’m sorry, this is very unusual to me, since the 3.3V regulator is fine, it seems to be a defective accelerometer.