Help! 3dr solo problem

Hello everyone!
I bought a solo a few weeks ago. I flew the solo once and everything was fine. A week later I went to fly it and it wouldn’t connect to the controller… I’ve tried doing the reset and it didn’t work. I even open the controller and reseated the microSD… turns out the orange led light under the solo is just solid once I power up the solo. Reading their website it says that that means there’s a problem with the onboard computer and to contact them. I emailed them more that a week ago and I’m still waiting for them to reply… has anyone had this problem? Or can anyone help me fix it?
Thank you!

This should be more in the arducopter category I think…

anyway, if i remember well orange means no connection to pixhawk… Did you try to factory reset everything?

Yes I reset the controller and the solo and it’s still not connecting

Ok for the controler but did you reset the solo?

I followed the steps on how to reset the solo, not sure if it worked or not.

did you see the quick flashing light on the solo?

It does not flash, it stays solid

The quickest thing to do is probably open the solo and check the SD Card that’s in there. See if it has popped loose or something. The card could be corrupt, and if so it can be reimaged on your PC.

then factory reset doesnt work, or you did it incorectly. the small led under the solo should flash really quick while resetting

While the solo is powering up it flashes but once the solo is on the light goes solid

I’m going to try opening up the solo and checking the sd card… if the card is corrupt how do I fix that?

Are you in the Solo Mod Club facebook group? There is a file there with a disk image for the SD card. I’ve never had to do it so I don’t have the process of the top of my head. But it’s not hard.

No I’m not… I opened up the solo and reseated the sd card and now it’s working! Thank you!

Excellent. You’re welcome.

I have the same issue, I have removed the SD card and loaded it on my PC but when I put the usb reader in all it says is this needs to be formatted, does that mean it is corrupted?

That is quite likely the case. You can re-image the SD card. The instructions are linked in the pinned post in the 3DR Solo Hacks facebook group. And that link takes you here:

1 Like